Opened 8 years ago

Closed 7 years ago

#48346 closed defect (worksforme)

julia @0.3.8: error: no member named 'move' in namespace 'std'

Reported by: kjy9308@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: petrrr
Port: julia

Description

hi,

i want to install Julia

so i wrote

->sudo port install julia

then

---> Staging julia into destroot
Error: org.macports.destroot for port julia returned: command execution
failed
Please see the log file for port julia for details:
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_julia/julia/main.log
To report a bug, follow the instructions in the guide:
http://guide.macports.org/#project.tickets
Error: Processing of port julia failed

what's problem?

Attachments (9)

main.log (1.2 MB) - added by kjy9308@… 8 years ago.
main.log
스크린샷.png (48.0 KB) - added by kjy9308@… 8 years ago.
output.png (11.2 KB) - added by kjy9308@… 8 years ago.
julia.main.log (1.2 MB) - added by petrrr 7 years ago.
a failing julia @0.3.9 build
error.png (103.8 KB) - added by kjy9308@… 7 years ago.
main.2.log (452.2 KB) - added by kjy9308@… 7 years ago.
julia_main.log (1.2 MB) - added by kjy9308@… 7 years ago.
julia_main_log.log (674.0 KB) - added by kjy9308@… 7 years ago.
julia_main_2.log (66.3 KB) - added by kjy9308@… 7 years ago.

Change History (39)

Changed 8 years ago by kjy9308@…

Attachment: main.log added

main.log

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to sean@…
Summary: julia_problemjulia @0.3.8: error: no member named 'move' in namespace 'std'

The log says the errors are:

:info:destroot In file included from codegen.cpp:25:
:info:destroot In file included from /opt/local/libexec/llvm-3.5/include/llvm/ExecutionEngine/ExecutionEngine.h:19:
:info:destroot In file included from /opt/local/libexec/llvm-3.5/include/llvm/ADT/SmallVector.h:17:
:info:destroot /opt/local/libexec/llvm-3.5/include/llvm/ADT/iterator_range.h:37:29: error: no member named 'move' in namespace 'std'
:info:destroot       : begin_iterator(std::move(begin_iterator)),
:info:destroot                        ~~~~~^
:info:destroot /opt/local/libexec/llvm-3.5/include/llvm/ADT/iterator_range.h:38:27: error: no member named 'move' in namespace 'std'
:info:destroot         end_iterator(std::move(end_iterator)) {}
:info:destroot                      ~~~~~^
:info:destroot /opt/local/libexec/llvm-3.5/include/llvm/ADT/iterator_range.h:49:33: error: no member named 'move' in namespace 'std'
:info:destroot   return iterator_range<T>(std::move(x), std::move(y));
:info:destroot                            ~~~~~^
:info:destroot In file included from codegen.cpp:25:
:info:destroot In file included from /opt/local/libexec/llvm-3.5/include/llvm/ExecutionEngine/ExecutionEngine.h:19:
:info:destroot In file included from /opt/local/libexec/llvm-3.5/include/llvm/ADT/SmallVector.h:20:
:info:destroot /opt/local/libexec/llvm-3.5/include/llvm/Support/MathExtras.h:21:10: fatal error: 'type_traits' file not found
:info:destroot #include <type_traits>
:info:destroot          ^
:info:destroot 4 errors generated.

comment:2 Changed 8 years ago by seanfarley (Sean Farley)

Do you have anything installed into /usr/local?

comment:3 Changed 8 years ago by kjy9308@…

/opt/local?

Last edited 8 years ago by kjy9308@… (previous) (diff)

Changed 8 years ago by kjy9308@…

Attachment: 스크린샷.png added

comment:4 Changed 8 years ago by seanfarley (Sean Farley)

No, I was wondering if anything in /usr/local was interfering with MacPorts. Could you paste the output of ls /usr/local? Otherwise, I will try to see if I can reproduce.

Changed 8 years ago by kjy9308@…

Attachment: output.png added

comment:5 Changed 8 years ago by kjy9308@…

output of /opt/local/

comment:6 Changed 8 years ago by mf2k (Frank Schima)

That is still not the correct directory requested by sean. Also, please do not paste images of text output and instead paste the text directly into the comment formatted with WikiFormatting.

comment:7 in reply to:  5 Changed 8 years ago by seanfarley (Sean Farley)

Replying to kjy9308@…:

output of /opt/local/

Thanks, but as mf2k noted, I asked for /usr/local not /opt/local. Please send the output (in text) of /usr/local.

comment:8 Changed 8 years ago by kjy9308@…

i'm sorry..!

output of /usr/local

No such files or directory

comment:9 Changed 8 years ago by seanfarley (Sean Farley)

Thanks for the reply. I'll have to think on this one.

comment:10 Changed 8 years ago by seanfarley (Sean Farley)

I've updated julia to 0.3.9. Can you test the upgrade?

comment:11 Changed 7 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:12 Changed 7 years ago by petrrr

I realize that this is a re-iteration of ticket #45900, which I file some time ago, but which was not really addressed.

I provide a second main.log from my systems build, it's a version 0.3.9 build.

BTW: Might this be a C++11 related issue?
I am still on a 10.8 with the standard setup (libstdc++, so no C++11 standard lib). If std::move() is a C++11 only feature, this might explain this issue. Just a thought, am an not really a C++ expert.

If more info or testing is needed, just let me know. I am very interested that this issue is sorted out.

Last edited 7 years ago by petrrr (previous) (diff)

Changed 7 years ago by petrrr

Attachment: julia.main.log added

a failing julia @0.3.9 build

comment:13 in reply to:  12 Changed 7 years ago by seanfarley (Sean Farley)

Replying to petr@…:

I realize that this is a re-iteration of ticket #45900, which I file some time ago, but which was not really addressed.

I provide a second main.log from my systems build, it's a version 0.3.9 build.

BTW: Might this be a C++11 related issue?
I am still on a 10.8 with the standard setup (libstdc++, so no C++11 standard lib). If std::move() is a C++11 only feature, this might explain this issue. Just a thought, am an not really a C++ expert.

If more info or testing is needed, just let me know. I am very interested that this issue is sorted out.

That's a good point. Can you try adding the usual '-std' flags that force C++11? If that works, then I can see if the portfile can handle that on 10.10.

comment:14 Changed 7 years ago by kjy9308@…

sorry for delay reply..

sudo port selfupdate 

and

sudo port install julia

then

what's wrong..?help me:(

Changed 7 years ago by kjy9308@…

Attachment: error.png added

comment:15 Changed 7 years ago by petrrr

If you provide the main.log, it usually be much more useful then any screenshot. If you want to cite a particular part of the output just paste it (and use Wiki formating).

It would be also useful to know, which system you are running on.

Please read and follow the Ticket Guideline!

Changed 7 years ago by kjy9308@…

Attachment: main.2.log added

comment:16 Changed 7 years ago by kjy9308@…

yes, i upload main.2.log

comment:17 Changed 7 years ago by petrrr

Not sure but your log file looks truncated. Is it complete? I get a 463 KB file.

:debug:main OS darwin/12.6.0 (Mac OS X 10.8) arch i386

So this might be the same issue described by me.

Which version of Xcode you are using?

libstdc++ or libc++?

comment:18 Changed 7 years ago by kjy9308@…

my Xcode's version is 5.1.1 i don't know libstdc++ or libc++ and i check main.log. this file size is 463KB.

comment:19 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: worksforme
Status: newclosed

Also, are you doing something like 'configure.compiler=macports-clang-3.5'? I'm going to mark this as 'worksforme' since I can't reproduce and haven't heard back from the reporter.

comment:20 Changed 7 years ago by petrrr

Sean, I'd suspect that this is a libstdc++ vs. libC++ issue, as 10.8.5. Unfortunately, I am not able to test any more because I updated some time ago.

comment:21 in reply to:  17 Changed 7 years ago by ryandesign (Ryan Schmidt)

Replying to petr@…:

Not sure but your log file looks truncated. Is it complete? I get a 463 KB file.

It is not truncated, but it is the log of the wrong port: it is the log of the activation of ncurses, rather than the log of the build of julia. MacPorts sometimes writes the wrong thing to the log. The workaround is to clean and try again.

comment:22 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: closedreopened

Has duplicate #48895 (which provides a good main.log file). The error was also previously mentioned in #45900 and also in #48701.

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:23 Changed 7 years ago by seanfarley (Sean Farley)

Still no idea.

comment:24 Changed 7 years ago by kjy9308@…

then is there a solution?

Changed 7 years ago by kjy9308@…

Attachment: julia_main.log added

comment:25 Changed 7 years ago by seanfarley (Sean Farley)

You could try upgrading to Yosemite and see if that works. If that doesn't work, then I would try building julia 0.4 to see if a newer llvm fixes.

Changed 7 years ago by kjy9308@…

Attachment: julia_main_log.log added

comment:26 Changed 7 years ago by kjy9308@…

i upgrade to Yosemite and install macport(for Yosemite)

so i install julia but fail..

i attach main.log(julia_main_log.log)

please help me..!

comment:27 Changed 7 years ago by seanfarley (Sean Farley)

Ok, looking at this now.

comment:28 Changed 7 years ago by kjy9308@…

umm..i uninstall macport and install mcport.

so i reupload julia_main_2.log

thank you and please help me..!

Changed 7 years ago by kjy9308@…

Attachment: julia_main_2.log added

comment:29 Changed 7 years ago by kjy9308@…

then is there a solution? help me:(

comment:30 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: worksforme
Status: reopenedclosed

I updated julia to 0.4 so hopefully that fixes this.

Note: See TracTickets for help on using tickets.