Opened 4 years ago

Closed 4 years ago

#48349 closed defect (fixed)

texlive-bin @2015_0: tetex scripts are broken

Reported by: mndavidoff (Monte Davidoff) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: mojca (Mojca Miklavec)
Port: texlive-bin

Description

The texlive @2015 +letter variant gets an error:

$ sudo port -vs install texlive +letter
...
sh: texconfig-sys: command not found
Command failed: texconfig-sys paper letter
Exit code: 127
Error: org.macports.activate for port texlive returned: command execution failed
Warning: targets not executed for texlive: org.macports.activate
Please see the log file for port texlive for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_tex_texlive/texlive/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port texlive failed

Attachments (1)

main.log.gz (8.8 KB) - added by mndavidoff (Monte Davidoff) 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by mndavidoff (Monte Davidoff)

Attachment: main.log.gz added

comment:1 Changed 4 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Cc: dports@… removed
Owner: changed from macports-tickets@… to dports@…

comment:3 Changed 4 years ago by drkp (Dan Ports)

Port: texlive-bin added; texlive removed
Status: newassigned
Summary: texlive @2015: +letter variant failstexlive @2015: tetex scripts are broken

Looks like the symlinks for all of the tetex scripts (texconfig, kpsetool, etc) are wrong. Presumably a bug in one of the texlive-bin patchfiles.

comment:4 Changed 4 years ago by drkp (Dan Ports)

Summary: texlive @2015: tetex scripts are brokentexlive-bin @2015_0: tetex scripts are broken

comment:5 Changed 4 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Fixed in r138677.

comment:6 Changed 4 years ago by mndavidoff (Monte Davidoff)

Resolution: fixed
Status: closedreopened

This problem is still occurring. It's been a while since r138677 was committed, which bumped the revision on texlive-bin, but I don't see it after a selfupdate.

$ $ port info texlive-bin | head -1
texlive-bin @2015 (tex)
$ grep Id: $(port file texlive-bin)
# $Id: Portfile 138601 2015-07-13 21:24:18Z dports@macports.org $

I see later changesets, so it's not some kind of selfupdate hang.

$ grep Id: $(port file texlive-basic)
# $Id: Portfile 138722 2015-07-17 05:35:29Z dports@macports.org $

Is there something else that needs to happen? Thanks!

Last edited 4 years ago by mndavidoff (Monte Davidoff) (previous) (diff)

comment:7 Changed 4 years ago by drkp (Dan Ports)

Resolution: fixed
Status: reopenedclosed

Oops, committed to the wrong branch. Fixed in r138732.

Note: See TracTickets for help on using tickets.