Opened 8 years ago

Closed 8 years ago

#48444 closed defect (fixed)

py27-exiv2: 'exiv2/image.hpp' file not found

Reported by: ctreleaven (Craig Treleaven) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: py-exiv2

Description

I'm trying to install Gramps3 (on a fresh Yosemite system) and it fails while installing y27-exiv2:

$ sudo port clean py27-exiv2 && sudo port install py27-exiv2
Password:
--->  Cleaning py27-exiv2
--->  Computing dependencies for py27-exiv2
--->  Fetching archive for py27-exiv2
--->  Attempting to fetch py27-exiv2-0.3.2_2.darwin_14.x86_64.tbz2 from http://packages.macports.org/py27-exiv2
--->  Attempting to fetch py27-exiv2-0.3.2_2.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/py27-exiv2
--->  Attempting to fetch py27-exiv2-0.3.2_2.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/py27-exiv2
--->  Fetching distfiles for py27-exiv2
--->  Verifying checksums for py27-exiv2
--->  Extracting py27-exiv2
--->  Applying patches to py27-exiv2
--->  Configuring py27-exiv2
--->  Building py27-exiv2
--->  Staging py27-exiv2 into destroot
Error: org.macports.destroot for port py27-exiv2 returned: command execution failed
Please see the log file for port py27-exiv2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-exiv2/py27-exiv2/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port py27-exiv2 failed

Main log attached; let me know if you need more info

Attachments (1)

main_py27-exiv2_2015Jul26.log (42.3 KB) - added by ctreleaven (Craig Treleaven) 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by ctreleaven (Craig Treleaven)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Port: py-exiv2 added; py27-exiv2 removed

comment:2 Changed 8 years ago by dbevans (David B. Evans)

Status: newassigned

comment:3 Changed 8 years ago by dbevans (David B. Evans)

First, a small disclaimer:

'gramps3' is an old (legacy) version of the program which is included for gtk2 compatibility. The current release is provided by the port 'gramps' which uses gtk3 and gexiv2. gexiv2 provides bindings to exiv2 using gobject introspection. This is the preferred approach and the use of py-exiv2 is now deprecated. I recommend using gramps rather than gramps3 unless you really need the gtk2 compatibility for some reason. The gtk3 version of gramps is now quite stable and the tentative plan is to obsolete gramps3 and py-exiv2 in the not too distant future.

Having said that, I can confirm that I see the same failure as reported but only sporadically. The problem is that the destroot env variables are not being consistently set as expected/required to give scons the right include path. Whether the build succeeds or not seems to be just the luck of the draw.

I've made some changes in the port in r139031 aimed at making the order in which these variables are set more consistent and I haven't seen any further destroot failures since doing so.

Let me know if this works better for you as well.

comment:4 Changed 8 years ago by ctreleaven (Craig Treleaven)

I confirm that the updated port installed successfully for me. Thank you for getting this working.

Also, thanks for the notes about gramps3. I do follow the gramps-users mailing list. I don't have time right now to deal with the differences in handling place information. For the time being, I just want to be able to reference my family tree. I use GTK very little--either version 2 or 3!

comment:5 in reply to:  4 Changed 8 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

Replying to ctreleaven@…:

I confirm that the updated port installed successfully for me. Thank you for getting this working.

Also, thanks for the notes about gramps3. I do follow the gramps-users mailing list. I don't have time right now to deal with the differences in handling place information. For the time being, I just want to be able to reference my family tree. I use GTK very little--either version 2 or 3!

I understand. Glad that the fix worked for you as well.

Just one last caution. If you do decide to upgrade to gramps(4), be sure and make a backup of your data in gramps3 first. gramps uses an updated database format and once it has updated your data to the new format, the database won't work with the earlier version anymore. See the notes in gramps about this.

Note: See TracTickets for help on using tickets.