Opened 6 years ago

Closed 4 years ago

#48540 closed defect (worksforme)

php54-cairo: configuration never completes

Reported by: carlosV2.0@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: php54-cairo

Description (last modified by Ionic (Mihai Moldovan))

Hi,

I'm trying to install the package "php-gtk" but it seems to have "php54-cairo" as a dependency. Trying to install this one I get this output:

--->  Configuring php54-cairo
DEBUG: Using compiler 'Xcode Clang'
DEBUG: Executing proc-pre-org.macports.configure-configure-0
DEBUG: Generating configure script in Cairo-0.3.2
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525

But it never completes this task. I've installed latest version of "xcode" but it still stacks in this step.

What should I do?

Thank you very much.

Change History (4)

comment:1 Changed 6 years ago by Ionic (Mihai Moldovan)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: php54-cairo added
Summary: php54-cairo configuration never completesphp54-cairo: configuration never completes

Please remember to CC the port maintainer(s), if any, next time and fill out the "Port" field.

comment:2 in reply to:  description Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to carlosV2.0@…:

Hi,

I'm trying to install the package "php-gtk" but it seems to have "php54-cairo" as a dependency.

Note that php-gtk is a stub port, just like all other ports whose names begin with "php-". They don't install anything. Instead, they serve as a placeholder for a package that is available for multiple PHP versions. The PHP GTK package is available for PHP 5.3 and 5.4, so you can choose which one you want to use. If you want to use PHP GTK with PHP 5.3, install php53-gtk. If you want to use it with PHP 5.4, install php54-gtk. If you try to install php-gtk, MacPorts will install the latest stable one, which is php54-gtk.

Trying to install this one I get this output:

--->  Configuring php54-cairo
DEBUG: Using compiler 'Xcode Clang'
DEBUG: Executing proc-pre-org.macports.configure-configure-0
DEBUG: Generating configure script in Cairo-0.3.2
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525

But it never completes this task. I've installed latest version of "xcode" but it still stacks in this step.

What should I do?

I have never seen this problem before... I'm not sure what to suggest.

Could you attach the main.log file? Its location is printed by the command:

port logfile php54-cairo

What version of OS X, Xcode and the Xcode command line tools are you using? What compiler version?

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Were you ever able to resolve this issue? If not, please attach the main.log file and add a comment to let me know.

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

We have prebuilt packages for php54-cairo for every version of Mac operating system from 10.5 to 10.12:

https://packages.macports.org/php54-cairo/

If it's not building for you, that points to a problem on your system, not a MacPorts bug.

Note: See TracTickets for help on using tickets.