Opened 5 years ago

Closed 4 years ago

#48577 closed defect (fixed)

subversion 1.9.0+ causes port lint Portfile property checks to fail

Reported by: dbevans (David B. Evans) Owned by: macports-tickets@…
Priority: Normal Milestone: MacPorts 2.3.5
Component: base Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt), neverpanic (Clemens Lang), Ionic (Mihai Moldovan), raimue (Rainer Müller), jmroot (Joshua Root)
Port:

Description

This concerns the behavior of the port lint command when the standard svn properties have not been set on a given Portfile.

Using subversion 1.8.14 and earlier, failure to set these properties on the Portfile results in the useful message:

--->  Verifying Portfile for argyll
Error: Missing subversion property on Portfile, please execute: svn ps svn:keywords Id Portfile
--->  1 errors and 0 warnings found.

However, after upgrading to subversion 1.9.0, the message is less helpful:

$ port lint
--->  Verifying Portfile for argyll
Warning: Unable to check for svn:keywords property: svn: warning: W200017: Property 'svn:keywords' not found on '/opt/macports/trunk/dports/graphics/argyll/Portfile'
svn: E200000: A problem occurred; see other errors for details
child process exited abnormally
--->  0 errors and 0 warnings found.

The cause is due to the fact that, in 1.9.0, subversion now considers it an error if propget is executed on a file when the target property does not exist.

In the earlier subversion versions, subversion does not generate an error and just returns with null output.

The current code depends on this latter behavior to identify when a property has not been set. If subversion returns an error, the error is printed as shown in the 1.9.0 case. The new 1.9.0 behavior in this situation needs to be accommodated as well as that of the older versions.

Tested in MacPorts 2.3.3 but examination of current subversion HEAD shows that the problem has not yet been dealt with.

Change History (5)

comment:1 Changed 5 years ago by Ionic (Mihai Moldovan)

Cc: ionic@… added

Cc Me!

comment:2 Changed 4 years ago by dbevans (David B. Evans)

Cc: raimue@… jmr@… added
Version: 2.3.32.3.4

Still an issue with MacPorts 2.3.4

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

Since we're moving from Subversion to Git and won't be using Subversion properties anymore, this lint check should be removed.

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Milestone: MacPorts 2.3.5

comment:5 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

r153865

This still needs to be added to the changelog (if we want it listed there), and merged to the 2.3 branch.

Note: See TracTickets for help on using tickets.