Opened 5 years ago

Closed 5 years ago

#48610 closed defect (fixed)

watch: build error with ncurses6

Reported by: macports@… Owned by: mjhsieh@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: haspatch Cc: ryandesign (Ryan Schmidt), fracai, J.Gilbey@…, bsoder@…, macports@…, mndavidoff (Monte Davidoff), neverpanic (Clemens Lang)
Port: watch

Description

trying to upgrade 'watch' to latest: 3.3.6_0 < 3.3.6_1

it depends on ncurses, which is currently 6.0, but is looking for /opt/local/bin/ncurses5-config and ultimately fails because it doesn't exist:

:notice:build --->  Building watch
:debug:build Executing proc-pre-org.macports.build-build-0
:error:build org.macports.build for port watch returned: couldn't execute "/opt/local/bin/ncurses5-config": no such file or directory
:debug:build Error code: NONE
:debug:build Backtrace: couldn't execute "/opt/local/bin/ncurses5-config": no such file or directory while executing

Attachments (2)

main.log (25.4 KB) - added by macports@… 5 years ago.
build log
watch.diff (692 bytes) - added by ryandesign (Ryan Schmidt) 5 years ago.
proposed patch

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by macports@…

Attachment: main.log added

build log

comment:1 Changed 5 years ago by macports@…

sorry, forgot to note build environment:

OS X Version 10.11 El Capitan Beta (15A243d) Xcode Version 7.0 beta 5 (7A176x)

(in case its somehow caused by the OS X or Xcode public betas)

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: haspatch added
Owner: changed from macports-tickets@… to mjhsieh@…

ncurses doesn't provide an ncurses-config program; they only provide one with a version number in it. So if we change "ncurses5-config" to "ncurses6-config", this is just going to break again when ncurses 7 is released. So let's fix it right, by using pkg-config, since the pkg-config file doesn't have a version number in it. Patch attached. @mjhsieh, if there are no objections, I'm happy to commit it.

Changed 5 years ago by ryandesign (Ryan Schmidt)

Attachment: watch.diff added

proposed patch

comment:3 Changed 5 years ago by fracai

Cc: arno@… added

Cc Me!

comment:4 Changed 5 years ago by J.Gilbey@…

Cc: J.Gilbey@… added

Cc Me!

comment:5 Changed 5 years ago by bsoder@…

Cc: bsoder@… added

Cc Me!

comment:6 Changed 5 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:7 Changed 5 years ago by mndavidoff (Monte Davidoff)

Cc: md14-macports@… added

Cc Me!

comment:8 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: cal@… added
Resolution: fixed
Status: newclosed

Clemens fixed this in r139496.

Note: See TracTickets for help on using tickets.