Opened 3 years ago

Closed 3 years ago

#48628 closed defect (duplicate)

KeePassX @2.0-beta1 configure error - zlib not found

Reported by: martin.desruisseaux@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: KeePassX

Description (last modified by mf2k (Frank Schima))

Attempt to install KeePassX on MacOS 10.7.5 fails with the log attached. I tried to clean everything (port -f uninstall installed followed by port clean all) then port selfupdate and port install KeePassX as the very first port to install. I also tried explicit port install zlib without success. The log contains the following lines:

:info:configure -- Found ZLIB: /opt/local/lib/libz.dylib (found version "1.2.8") 
:info:configure -- Performing Test ZLIB_SUPPORTS_GZIP
:info:configure -- Performing Test ZLIB_SUPPORTS_GZIP - Failed
:info:configure CMake Error at CMakeLists.txt:187 (message):
:info:configure   zlib 1.2.x or higher is required to use the gzip format

port installed zlib gives me:

The following ports are currently installed:
  zlib @1.2.8_0 (active)

My XCode version is 4.6.3 (the latest one compatible with MacOS 10.7).

This issue seems related to ticket:38906 but the later is 2 years old and marked as "fixed".

Attachments (1)

main.log (42.5 KB) - added by martin.desruisseaux@… 3 years ago.

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by martin.desruisseaux@…


comment:1 Changed 3 years ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:2 Changed 3 years ago by mf2k (Frank Schima)

  • Resolution set to duplicate
  • Status changed from new to closed

Per the comment in ticket:38906#comment:9, please do not file a duplicate ticket but instead re-open that one.

Note: See TracTickets for help on using tickets.