Opened 7 years ago

Closed 7 years ago

#49062 closed defect (fixed)

CCL port fails to build with Xcode 7

Reported by: ndbrowne@… Owned by: easye
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: yosemite elcapitan Cc: fu7mu4 (fu7mu4), ryandesign (Ryan Schmidt)
Port: ccl

Description

CCL is failing to build. I have installed other ports (OCaml and Python35) without issue

Attachments (2)

ccl.from.main.log (4.9 KB) - added by ndbrowne@… 7 years ago.
ccl build info from main.log
ccl.from.main.2.log (792.5 KB) - added by ndbrowne@… 7 years ago.
log of ccl build after cleaning the port

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by ndbrowne@…

Attachment: ccl.from.main.log added

ccl build info from main.log

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: ccl failure removed
Port: ccl added; CCL removed

This log was not from a clean build attempt. Please clean and try again.

Changed 7 years ago by ndbrowne@…

Attachment: ccl.from.main.2.log added

log of ccl build after cleaning the port

comment:2 Changed 7 years ago by fu7mu4 (fu7mu4)

On my mac(El Capitan), the ccl port is failed to build too. something happend during the lisp kernel rebuilding.

comment:3 Changed 7 years ago by ndbrowne@…

A log file from a clean ccl build that failed is attached.

comment:4 Changed 7 years ago by fu7mu4 (fu7mu4)

This problem was reproduced in original distributed ccl 1.10 (not macports) and solved in original. I have been teached from rme by irc #ccl on irc.freenode.net. thanks rme.


You can add "-Q" to ASFLAGS in lisp-kernel/darwinx8664/Makefile and that will enable you to compile the lisp kernel. Or, you can switch to the 1.11 pre-release branch. http://ccl.clozure.com/blog/?p=178 In 10.11, the default assembler is the clang integrated assembler, and it doesn't understand .stabs directives. The -Q flag makes it use the prior, separate assembler.


lisp-kernel/darwinx8664/Makefile is exist bellow "the ccl directory", in macport, it means

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_ccl/ccl/work/ccl/lisp-kernel/darwinx8664/Makefile

comment:5 Changed 7 years ago by fu7mu4 (fu7mu4)

here is my step to install ccl 1.10 on El Caption

  1. configure ccl source by macports way
sudo port clean ccl
sudo port configure ccl
  1. change directory in order to edit Makefile
cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_ccl/ccl/work/ccl/lisp-kernel/darwinx8664/
sudo vi Makefile    #only change line 52 of it. see bellow lines before edit
diff -u Makefile~ Makefile
cd -

You add "-Q" to ASFLAGS in Makefile, like this. (diff -u Makefile~ Makefile)

--- Makefile~	2015-10-03 09:48:46.000000000 +0900
+++ Makefile	2015-10-03 10:46:19.000000000 +0900
@@ -49,7 +49,7 @@
 ###
 ### Apple never
 M4FLAGS = -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR
-ASFLAGS = -arch x86_64 -g
+ASFLAGS = -arch x86_64 -g -Q
 CDEFINES = -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION=$(SVN_REVISION) \
 	   -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE
 CDEBUG = -g
  1. build and install
sudo port -d build ccl
sudo port -d destroot ccl
sudo port -d install ccl

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: fu7mu4@… added
Keywords: elcapitan added
Owner: changed from macports-tickets@… to easieste@…

I have no problem installing ccl 1.10 on OS X 10.11 El Capitan with Xcode 7.0.1. What version of Xcode do the people affected by this bug have?

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:8 Changed 7 years ago by fu7mu4 (fu7mu4)

My Xcode version is also 7.0.1 ! I don't know why.

comment:9 Changed 7 years ago by fu7mu4 (fu7mu4)

I have tried to install via macports (builed with Xcode 7.0.1 and Command Line Tools 10.10 for Xcode 7) but that failed as it report above. Today, I tried to do (build with Xcode 7.0.1 and Command Line Tools 10.11 for Xcode 7.1 beta 3) but it failed too.

comment:10 Changed 7 years ago by alexey.n@…

Fails to build on OS X 10.11.1 / Xcode 7.1 (7B91b) / Command Line Tools for Xcode, Version 7.1.

:debug:build Executing org.macports.build (ccl)
:info:build sh: ./dx86cl64: No such file or directory
:info:build Command failed: cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_ccl/ccl/work/ccl && echo '(ccl::rebuild-ccl :full t)' | ./dx86cl64 --batch
:info:build Exit code: 127

The solution with adding -Q to ASFLAGS works.

comment:11 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: yosemite added
Resolution: fixed
Status: newclosed
Summary: CCL port fails to build under El Capitan (10.11)CCL port fails to build with Xcode 7
Note: See TracTickets for help on using tickets.