Opened 7 years ago

Closed 7 years ago

#49063 closed defect (duplicate)

wireshark: build fails with lua 5.3

Reported by: breiter (Brian Reiter) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: wireshark

Description

Build error for wireshark since upgrading to El Capitan, 10.11. It builds successfully with -lua.

:info:build Making all in wslua
:info:build make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/work/wireshark-1.12.7/epan/wslua'
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make  all-am
:info:build make[4]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/work/wireshark-1.12.7/epan/wslua'
:info:build   CC       lua_bitop.lo
:info:build   CC       lrexlib.lo
:info:build   CC       lrexlib_glib.lo
:info:build   CC       lrexlib_glib_f.lo
:info:build   CC       wslua_tvb.lo
:info:build   CC       wslua_proto.lo
:info:build   CC       wslua_int64.lo
:info:build   CC       wslua_tree.lo
:info:build ./lua_bitop.c:85:2: error: "Unknown number type, check LUA_NUMBER_* in luaconf.h"
:info:build #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
:info:build  ^
:info:build 1 error generated.
:info:build make[4]: *** [lua_bitop.lo] Error 1
:info:build make[4]: *** Waiting for unfinished jobs....
:info:build In file included from ./lrexlib_glib.c:199:
:info:build ./lrexlib_algo.h:121:21: warning: implicit declaration of function 'luaL_optint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build   int startoffset = luaL_optint(L, stackpos, 1);
:info:build                     ^
:info:build ./wslua_tree.c:211:16: warning: implicit declaration of function 'luaL_checkint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build     encoding = wslua_checkguint(L,1);
:info:build                ^
:info:build ./wslua.h:83:53: note: expanded from macro 'wslua_checkguint'
:info:build #define wslua_checkguint(L,i)   (guint)           ( luaL_checkint(L,i) )
:info:build                                                     ^
:info:build ./wslua_tree.c:524:29: warning: implicit declaration of function 'luaL_optint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build     int group             = luaL_optint(L,WSLUA_OPTARG_TreeItem_add_expert_info_GROUP,PI_DEBUG);
:info:build                             ^
:info:build ./wslua_int64.c:272:14: warning: implicit declaration of function 'luaL_optint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build     gint n = luaL_optint(L, WSLUA_OPTARG_Int64_new_NUMBYTES, 16);
:info:build              ^
:info:build ./wslua_tvb.c:157:15: warning: implicit declaration of function 'luaL_checkint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build     int siz = luaL_checkint(L,WSLUA_ARG_ByteArray_set_size_SIZE);
:info:build               ^
:info:build ./wslua_tvb.c:280:28: warning: implicit declaration of function 'luaL_optint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build     guint offset = (guint) luaL_optint(L,WSLUA_OPTARG_ByteArray_raw_OFFSET,0);
:info:build                            ^
:info:build ./wslua_proto.c:757:29: warning: implicit declaration of function 'luaL_checkint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build         type = (enum ftenum)luaL_checkint(L,WSLUA_ARG_ProtoField_new_TYPE);
:info:build                             ^
:info:build ./wslua_proto.c:765:16: warning: implicit declaration of function 'luaL_optint' is invalid in C99 [-Wimplicit-function-declaration]
:info:build         base = luaL_optint(L, WSLUA_OPTARG_ProtoField_new_BASE, BASE_NONE);
:info:build                ^

Attachments (1)

main.log (279.9 KB) - added by breiter (Brian Reiter) 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by breiter (Brian Reiter)

Attachment: main.log added

comment:1 Changed 7 years ago by breiter (Brian Reiter)

Duplicate of #48835.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: elcapitan removed
Resolution: duplicate
Status: newclosed
Summary: wiresharkwireshark: build fails with lua 5.3
Note: See TracTickets for help on using tickets.