Opened 3 years ago

Closed 3 years ago

#49068 closed defect (duplicate)

gcc48: error: missing binary operator before token "("

Reported by: yannis1962@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: elcapitan Cc:
Port: gcc48

Description (last modified by ryandesign (Ryan Schmidt))

--->  Computing dependencies for gcc48
--->  Building gcc48
Error: org.macports.build for port gcc48 returned: command execution failed
Please see the log file for port gcc48 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_www.macports.org_files_ports_lang_gcc48/gcc48/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

System: El Capitan
XCode:7.0.1 (7A1001)

Attachments (2)

MacBook Pro.spx (6.5 MB) - added by yannis1962@… 3 years ago.
main.log (43.3 KB) - added by yannis1962@… 3 years ago.

Change History (3)

Changed 3 years ago by yannis1962@…

Attachment: MacBook Pro.spx added

Changed 3 years ago by yannis1962@…

Attachment: main.log added

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: elcapitan added
Port: gcc48 added
Resolution: duplicate
Status: newclosed
Summary: Error: org.macports.build for port gcc48 returned: command execution failedgcc48: error: missing binary operator before token "("

The error message says:

/usr/include/Availability.h:219:22: error: missing binary operator before token "("

Duplicate of #48471.

Note: See TracTickets for help on using tickets.