Opened 4 years ago

Closed 4 years ago

#49153 closed defect (fixed)

python_select does not know about El Capitan versions of python

Reported by: chazapis@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: elcapitan Cc: kurtjaeke@…, ryandesign (Ryan Schmidt)
Port: python_select

Description

I have two issues with Python 2.7 (2.7.10) in El Capitan:

  • The port select command does not recognize the default Python provided by Apple:
$ port select python
Available versions for python:
	none (active)
	python27
  • When I run the MacPorts version of Python and then exit the Python shell, my terminal session is messed up (whatever I type does not show up and all terminal output is on the same line), until I issue a reset command:
$ /opt/local/bin/python2.7
Python 2.7.10 (default, Oct  7 2015, 13:02:49) 
[GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.72)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> ^D>>> 
$ $ $ $ 

I tried both the packaged version and recompiling all packages locally (I have the latest Xcode installed and all updates).

Change History (6)

comment:1 Changed 4 years ago by stromnov (Andrew Stromnov)

Second issue is a duplicate of #48807.

comment:2 Changed 4 years ago by m7.thon@…

First issue is not an issue. This is how port select has worked for a while. To default to the system python (or whatever else is configured outside macports), just select none.

comment:3 in reply to:  2 ; Changed 4 years ago by ryandesign (Ryan Schmidt)

Keywords: elcapitan added
Port: python_select added
Summary: Python problems in El Capitanpython_select does not know about El Capitan versions of python

Replying to m7.thon@…:

First issue is not an issue. This is how port select has worked for a while.

No; it is a bug in the python_select port. It needs to have an appropriate "platform darwin 15" block added to it, and its revision increased.

comment:4 Changed 4 years ago by chazapis@…

Indeed, looking at #48807, I found that installing Python with port install python27 +readline solves the terminal issue.

That was very helpful. Thanks.

Last edited 4 years ago by chazapis@… (previous) (diff)

comment:5 Changed 4 years ago by kurtjaeke@…

Cc: kurtjaeke@… added

Cc Me!

comment:6 in reply to:  3 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed

Replying to ryandesign@…:

It needs to have an appropriate "platform darwin 15" block added to it, and its revision increased.

r141426

Note: See TracTickets for help on using tickets.