Opened 4 years ago

Closed 4 years ago

#49187 closed defect (fixed)

ceres-solver @1.10.0: CeresConfig.cmake requires eigen3@3.2.2 instead of @3.2.5

Reported by: cignoni (Paolo Cignoni) Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: ceres-solver

Description

for the port ceres-solver the corresponding CeresConfig.cmake specifies that it requires eigen3@3.2.2 but if you have the current eigen3 @3.2.5 it fails to satisfy the requirements

I encountered this bug when building openMVS ( https://github.com/OpenMVS ) on a osx 10.10.5 with xcode 7.0.1 installed.

I manually changed the CeresConfig.cmake to specify current eigen3 @3.2.5 and it successfully compiled.

Change History (3)

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mmoll@…
Port: ceres-solver added
Summary: ceres-solver CeresConfig.cmake requires eigen3@3.2.2 instead of @3.2.5ceres-solver @1.10.0: CeresConfig.cmake requires eigen3@3.2.2 instead of @3.2.5
Type: updatedefect

comment:2 Changed 4 years ago by mamoll (Mark Moll)

Fixed in r141079.

comment:3 Changed 4 years ago by mamoll (Mark Moll)

Resolution: fixed
Status: newclosed

should be fixed (and has been for a while).

Note: See TracTickets for help on using tickets.