Opened 6 years ago

Closed 5 years ago

#49293 closed defect (invalid)

Checksum mismatch for freetype-2.6.1.tar.bz2

Reported by: ole.rosendahl@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: freetype

Description

Doing an sudo port upgrade outdated breaks with a checksum mismatch:

--->  Computing dependencies for freetype
--->  Fetching archive for freetype
--->  Attempting to fetch freetype-2.6.1_0.darwin_13.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/freetype
--->  Attempting to fetch freetype-2.6.1_0.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/freetype
--->  Attempting to fetch freetype-2.6.1_0.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/freetype
--->  Fetching distfiles for freetype
--->  Verifying checksums for freetype
Error: Checksum (rmd160) mismatch for freetype-2.6.1.tar.bz2
Error: Checksum (sha256) mismatch for freetype-2.6.1.tar.bz2
Error: org.macports.checksum for port freetype returned: Unable to verify file checksums
Please see the log file for port freetype for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_freetype/freetype/main.log
Error: Unable to upgrade port: 1

Mac OS 10.9.5 Xcode 6.2

File main.log is attached.

Attachments (1)

main.log (4.7 KB) - added by ole.rosendahl@… 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by ole.rosendahl@…

Attachment: main.log added

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ryandesign@…

In the future, please Cc the port maintainers (port info --maintainers freetype), if any.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Did you read wiki:FAQ#checksums and try to figure out which case applies in your situation? The output above does not tell us what server the bad distfile came from.

comment:3 Changed 6 years ago by ole.rosendahl@…

Stupid me! RTFM. Wike-link solved the issue, thank you @ryandesign.

@mf2k: Thank you for pointing this out to me. Next ticket…

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

So was it a problem on your end, or a corrupted download? Or is there a server with a bad file that we need to exclude?

comment:5 Changed 6 years ago by ole.rosendahl@…

I just followed the first aid instructions in the Wiki-article:

sudo port selfupdate
sudo port clean --dist freetype
sudo port install freetype

and everything was fine.

comment:6 Changed 6 years ago by essandess (Steve Smith)

CC me. selfupdate && clean --dist isn't working for me.

cat `sudo port file freetype`

checksums               ${distname}${extract.suffix} \
                        rmd160  367c47b88752ab3ff09b06b43cf3f9d79ef71ca0 \
                        sha256  2f6e9a7de3ae8e85bdd2fe237e27d868d3ba7a27495e65906455c27722dd1a17 \
                        ${docdistname}${extract.suffix} \
                        rmd160  61daf25c38e9da3d6057b2695eb435fc93345646 \
                        sha256  69b1102c9f4e7d75ad2701618f7e5c084d819264755ecbf11893e3cc6de0e0f5

Looks like an errant server.

Last edited 6 years ago by essandess (Steve Smith) (previous) (diff)

comment:7 Changed 6 years ago by essandess (Steve Smith)

Whoops. I believe the problem is on my end. I reconfigured macports.conf to stop proxying through a filtering proxy and the hash mismatches on HTML downloads disappeared.

comment:8 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.