Opened 5 years ago

Closed 2 years ago

#49341 closed defect (fixed)

slime @2.14: slime.texi: Unknown command `codequoteundirected'. Unknown command `codequotebacktick'.

Reported by: ReddyKilowatt (Reddy Kilowatt) Owned by: easye
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: davocado, ephemeris@…, ryandesign (Ryan Schmidt)
Port: slime

Description (last modified by ryandesign (Ryan Schmidt))

I've tried building, cleaning 5 separate times, each results in the same failure

Error: org.macports.build for port slime returned: command execution failed

Attachments (1)

main.log (54.3 KB) - added by ReddyKilowatt (Reddy Kilowatt) 5 years ago.
slime build log file

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by ReddyKilowatt (Reddy Kilowatt)

Attachment: main.log added

slime build log file

comment:1 Changed 5 years ago by ReddyKilowatt (Reddy Kilowatt)

All of the previous reports for this error had no resolution. They all stated to clean and build again. I've done that, the problem still persists.

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: slime lisp removed
Owner: changed from macports-tickets@… to easieste@…
Summary: Building slime fails on Mavericksslime @2.14: slime.texi: Unknown command `codequoteundirected'. Unknown command `codequotebacktick'.

Let's call #47252 a duplicate of this ticket, since although it's older than this ticket, this ticket is the first one to provide a log from a clean build.

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

The latest build of slime failed on all buildbot builders for the reason in this ticket, e.g.:

https://build.macports.org/builders/ports-10.11_x86_64-builder/builds/1214

comment:4 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: davocado ephemeris@… added

Has duplicate #54304.

comment:5 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

comment:6 Changed 2 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

In 45ea22b51dc642571ab1f784066251e6b5b75d61/macports-ports:

slime: Add texinfo build dependency

The older version included with macOS can't build this.

Closes: #49341

Note: See TracTickets for help on using tickets.