Opened 3 years ago

Closed 2 years ago

#49416 closed defect (worksforme)

aarnet mirror server delivers wrong files

Reported by: ady.romantika@… Owned by: mirror@…
Priority: Normal Milestone:
Component: server/hosting Version: 2.3.4
Keywords: Cc: larryv (Lawrence Velázquez), ryandesign (Ryan Schmidt), michael@…, jmarchbold@…
Port:

Description

Hi, I am having an issue upgrading libtool on OXS 10.11.1

$ sudo port upgrade libtool
--->  Verifying checksums for libtool
Error: Checksum (rmd160) mismatch for libtool-2.4.6.tar.gz
Error: Checksum (sha256) mismatch for libtool-2.4.6.tar.gz
Error: org.macports.checksum for port libtool returned: Unable to verify file checksums
Please see the log file for port libtool for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libtool/libtool/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

Attachments (2)

main.log (2.4 KB) - added by ady.romantika@… 3 years ago.
Log file
main.2.log (2.5 KB) - added by jmarchbold@… 3 years ago.
log at 26/10/2015

Download all attachments as: .zip

Change History (20)

Changed 3 years ago by ady.romantika@…

Attachment: main.log added

Log file

comment:1 Changed 3 years ago by ady.romantika@…

Removed. Attempted to edit typo in description field.

Last edited 3 years ago by ady.romantika@… (previous) (diff)

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Please read wiki:FAQ#checksums and try to figure out why the checksum mismatch occurred.

comment:3 Changed 3 years ago by ady.romantika@…

I have no idea why but the distfile was a PGP signature:

$ file /opt/local/var/macports/distfiles/libtool/libtool-2.4.6.tar.gz
/opt/local/var/macports/distfiles/libtool/libtool-2.4.6.tar.gz: PGP signature

I ran

$ sudo port clean --dist libtool
$ sudo port upgrade libtool

And the correct file is now there:

$ file /opt/local/var/macports/distfiles/libtool/libtool-2.4.6.tar.gz
/opt/local/var/macports/distfiles/libtool/libtool-2.4.6.tar.gz: gzip compressed data, from Unix, max compression

All is well now, thanks.

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: checksum removed
Summary: libtool checksum mismatchaarnet mirror server delivers wrong files

This is because the aarnet mirror server is misconfigured:

$ curl -I -L http://mirror.aarnet.edu.au/pub/gnu/libtool/libtool-2.4.6.tar.gz
HTTP/1.1 200 OK
Date: Sat, 24 Oct 2015 16:47:36 GMT
Server: ATS/5.2.0
Content-Location: libtool-2.4.6.tar.gz.sig
Vary: negotiate
TCN: choice
Last-Modified: Sun, 15 Feb 2015 20:31:58 GMT
Accept-Ranges: bytes
Content-Length: 181
Content-Type: application/pgp-signature
Age: 192

I reported this problem to them already in a different context on October 13 along with the fix (add "Options -MultiViews" to the Apache configuration). I will remind them about the problem again.

comment:5 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; ryandesign@… removed
Port: libtool removed

comment:6 Changed 3 years ago by larryv (Lawrence Velázquez)

Cc: michael@… added

Cc-ing another user who had similar problems with that mirror and reported it to me via email.

comment:7 Changed 3 years ago by ryandesign (Ryan Schmidt)

Component: portsserver/hosting
Owner: changed from macports-tickets@… to mirror@…

Assigning to admin of server.

comment:8 Changed 3 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: newclosed

Admin says this is fixed:

00:30:15  classicsnail) good morning, mirror.aarnet.edu.au maintainer here, I'm looking at https://trac.macports.org/ticket/49416
00:30:38  classicsnail) for some reason our ticket tracking system has started stripping out email addresses, so I ahven't been able to reply, but I've changed the configuration

comment:9 Changed 3 years ago by jmarchbold@…

Resolution: fixed
Status: closedreopened

I have been trying to install libtool as well. No progress yet ..
Log from Mon 26th Oct, 8.35AM GST+10

sh-3.2# sudo port clean --dist libtool
--->  Cleaning libtool
sh-3.2# sudo port upgrade libtool
Error: libtool is not installed
sh-3.2# sudo port install libtool
--->  Fetching archive for libtool
--->  Attempting to fetch libtool-2.4.6_2.darwin_15.x86_64.tbz2 from http://packages.macports.org/libtool
--->  Attempting to fetch libtool-2.4.6_2.darwin_15.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/libtool
--->  Attempting to fetch libtool-2.4.6_2.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/libtool
--->  Fetching distfiles for libtool
--->  Attempting to fetch libtool-2.4.6.tar.gz from http://mirror.aarnet.edu.au/pub/gnu/libtool
--->  Verifying checksums for libtool
Error: Checksum (rmd160) mismatch for libtool-2.4.6.tar.gz
Error: Checksum (sha256) mismatch for libtool-2.4.6.tar.gz
Error: org.macports.checksum for port libtool returned: Unable to verify file checksums
Please see the log file for port libtool for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libtool/libtool/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port libtool failed
sh-3.2# 
Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 3 years ago by jmarchbold@…

Attachment: main.2.log added

log at 26/10/2015

comment:10 Changed 3 years ago by ryandesign (Ryan Schmidt)

Agreed, the command shown above shows that the problem still exists.

comment:11 Changed 3 years ago by damo.clarky@…

I can confirm also that the problem still exists - output of main.log

:notice:fetch --->  Attempting to fetch libtool-2.4.6.tar.gz from http://mirror.aarnet.edu.au/pub/gnu/libtool
:debug:fetch Privilege de-escalation not attempted as not running as root.
:debug:checksum checksum phase started at Tue Oct 27 10:10:15 AEST 2015
:notice:checksum --->  Verifying checksums for libtool
:debug:checksum Executing org.macports.checksum (libtool)
:info:checksum --->  Checksumming libtool-2.4.6.tar.gz
:debug:checksum Calculated (rmd160) is 9ff43e244ef621dd9af961f9122409d7d88a9de0
:error:checksum Checksum (rmd160) mismatch for libtool-2.4.6.tar.gz
:info:checksum Portfile checksum: libtool-2.4.6.tar.gz rmd160 6f4b4c3e89426652da3acffa707f71bb4ccee26a
:info:checksum Distfile checksum: libtool-2.4.6.tar.gz rmd160 9ff43e244ef621dd9af961f9122409d7d88a9de0
:debug:checksum Calculated (sha256) is 8af306744d7095f08b090678fc7570d58499e697a0216e423d806b70fe483ea0
:error:checksum Checksum (sha256) mismatch for libtool-2.4.6.tar.gz
:info:checksum Portfile checksum: libtool-2.4.6.tar.gz sha256 e3bd4d5d3d025a36c21dd6af7ea818a2afcd4dfc1ea5a17b39d7854bcd0c06e3
:info:checksum Distfile checksum: libtool-2.4.6.tar.gz sha256 8af306744d7095f08b090678fc7570d58499e697a0216e423d806b70fe483ea0
:info:checksum The correct checksum line may be:
:info:checksum checksums           rmd160  9ff43e244ef621dd9af961f9122409d7d88a9de0 \
                    sha256  8af306744d7095f08b090678fc7570d58499e697a0216e423d806b70fe483ea0
:error:checksum org.macports.checksum for port libtool returned: Unable to verify file checksums
:debug:checksum Error code: NONE
:debug:checksum Backtrace: Unable to verify file checksums
    while executing
"portchecksum::checksum_main org.macports.checksum"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"

comment:12 in reply to:  4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

This is because the aarnet mirror server is misconfigured:

$ curl -I -L http://mirror.aarnet.edu.au/pub/gnu/libtool/libtool-2.4.6.tar.gz
HTTP/1.1 200 OK
Date: Sat, 24 Oct 2015 16:47:36 GMT
Server: ATS/5.2.0
Content-Location: libtool-2.4.6.tar.gz.sig
Vary: negotiate
TCN: choice
Last-Modified: Sun, 15 Feb 2015 20:31:58 GMT
Accept-Ranges: bytes
Content-Length: 181
Content-Type: application/pgp-signature
Age: 192

I reported this problem to them already in a different context on October 13 along with the fix (add "Options -MultiViews" to the Apache configuration). I will remind them about the problem again.

The different context I mentioned was reported to us in #49209 and that issue (receiving an HTML file that happened to be in the same directory instead of the requested tarball) is resolved. However, the issue reported here (receiving a PGP signature file that happened to be in the same directory instead of the requested tarball) remains. I also see now that this server is not running Apache httpd but rather Apache Traffic Server; I don't know how to configure that.

comment:13 Changed 3 years ago by ryandesign (Ryan Schmidt)

Has duplicate #49371.

comment:14 Changed 3 years ago by ryandesign (Ryan Schmidt)

I've temporarily removed the aarnet mirror from the gnu fetch group in r141733; this can be reverted when the server configuration is fixed. I'm not sure if any of the other groups aarnet provides mirrors for use pgg signature files too; if so, we can temporarily remove aarnet from those groups as well.

comment:15 Changed 3 years ago by jmarchbold@…

Hi Ryan, Not sure what I am doing wrong here, but main.log reports that it can't find the file:libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2.

From main.log -

:info:archivefetch --->  libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/ver$
:msg:archivefetch --->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://packages.macports.org/libtool
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://jog.id.packages.macports.org/m$
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://lil.fr.packages.macports.org/l$
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found

From the command:

JohnArcboldsMBP:~ John$ sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.3.4 installed,
MacPorts base version 2.3.4 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version
The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
JohnArcboldsMBP:~ John$ sudo port clean libtool
--->  Cleaning libtool
JohnArcboldsMBP:~ John$ sudo port upgrade outdated
--->  Fetching archive for libtool
--->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://packages.macports.org/libtool
--->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/libtool
--->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://lil.fr.packages.macports.org/libtool
--->  Fetching distfiles for libtool
--->  Verifying checksums for libtool
Error: Checksum (rmd160) mismatch for libtool-2.4.6.tar.gz
Error: Checksum (sha256) mismatch for libtool-2.4.6.tar.gz
Error: org.macports.checksum for port libtool returned: Unable to verify file checksums
Please see the log file for port libtool for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libtool/libtool/main.log
Error: Problem while installing libtool
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
JohnArcboldsMBP:~ John$
Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:16 in reply to:  15 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: jmarchbold@… added

Replying to jmarchbold@…:

Hi Ryan, Not sure what I am doing wrong here, but main.log reports that it can't find the file:libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2.

From main.log -

:info:archivefetch --->  libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/ver$
:msg:archivefetch --->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://packages.macports.org/libtool
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://jog.id.packages.macports.org/m$
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch libtool-2.4.6_2+universal.darwin_15.i386-x86_64.tbz2 from http://lil.fr.packages.macports.org/l$
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found

There are no archives of any port available for darwin 15 at this time. This is not a bug, just a missing nice-to-have optional time-saving feature. See #48609.

From the command:

JohnArcboldsMBP:~ John$ sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.3.4 installed,
MacPorts base version 2.3.4 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version
The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
JohnArcboldsMBP:~ John$ sudo port clean libtool
--->  Cleaning libtool

This does not clean (remove) the distfile. To clean (remove) the distfile, run:

sudo port clean --dist libtool

or

sudo port clean --all libtool

Then try again.

comment:17 Changed 3 years ago by jmarchbold@…

Thanks - that worked. Cheers

comment:18 Changed 2 years ago by raimue (Rainer Müller)

Resolution: worksforme
Status: reopenedclosed

Hopefully the original problem is no longer existent.

As a side note, I fixed the mirror URL for the MacPorts distfiles mirroring for this server in [8c59d6596c49b57139f61df07ab1acc9e9fa96fd/macports-ports].

Note: See TracTickets for help on using tickets.