Opened 3 years ago

Closed 3 years ago

#49442 closed defect (worksforme)

dsniff @2.4: configure: error: Berkeley DB with 1.85 compatibility not found

Reported by: cse9423@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: dsniff

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

I am trying to run "sudo port install dsniff" command from terminal window and getting an error "Error: Processing of port dsniff failed". I am running at OS X El Capitan (10.11). I have attached the error message and log file content. Any help greatly appreciated.

Terminal console message:

Error: Failed to configure dsniff, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/work/dsniff-2.4/config.log
Error: org.macports.configure for port dsniff returned: configure failure: command execution failed
Please see the log file for port dsniff for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port sniff failed

Main.log file content

checking for Berkeley DB with 1.85 compatibility... configure: error: Berkeley DB with 1.85 compatibility not found
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/work/dsniff-2.4" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man 
:info:configure Exit code: 1
:error:configure Failed to configure dsniff, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/work/dsniff-2.4/config.log
:error:configure org.macports.configure for port dsniff returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"portconfigure::configure_main org.macports.configure"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:configure Warning: targets not executed for dsniff: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port dsniff for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/main.log

Change History (3)

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to cal@…
Port: dsniff added
Summary: Error: Processing of port sniff failed in OS X 10.11dsniff @2.4: configure: error: Berkeley DB with 1.85 compatibility not found

Please use WikiFormatting, don't forget to fill in the port name and maintainer email address, and use copy/paste for commands you typed and errors you received, so that you do not introduce typos (such as the auto-"corrected" dsniff -> sniff).

comment:2 Changed 3 years ago by cse9423@…

Any solution for this issue?

comment:3 Changed 3 years ago by neverpanic (Clemens Lang)

Resolution: worksforme
Status: newclosed

Doesn't happen for me on El Cap. My guess is that you don't have the command line tools installed, which come with db.h. If /usr/include/db.h doesn't exist on your system that is definitely the cause.

Please re-open if that's not the case.

Note: See TracTickets for help on using tickets.