Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#49451 closed defect (fixed)

bibutils @4.12_1: distfile not available

Reported by: paoloit@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: jochen@…
Port: bibutils

Description

Retrieval of bibutils package fails for all archive sites;

The http://XXX.distfiles.macports.org/bibutils/ directories (full listing given below) contain a single bibutils_4.12_src.tgz.html file (mostly with timestamps from Oct 23…Oct 25, 2015; the timestamp for http://osl.no.distfiles.macports.org/bibutils/ is Oct 9). This HTML file displays a "Protein Calculator".

Full trace (logfile also attached):

[pathname omitted] > fetch bibutils
--->  Fetching distfiles for bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://lil.fr.distfiles.macports.org/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://nue.de.distfiles.macports.org/macports/distfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://osl.no.distfiles.macports.org/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://her.gr.distfiles.macports.org/mirrors/macports/mpdistfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://sea.us.distfiles.macports.org/macports/distfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://distfiles.macports.org/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://jog.id.distfiles.macports.org/macports/mpdistfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://cjj.kr.distfiles.macports.org/bibutils
--->  Attempting to fetch bibutils_4.12_src.tgz from http://www.scripps.edu/~cdputnam/software/bibutils/
--->  Attempting to fetch bibutils_4.12_src.tgz from http://svn.macports.org/repository/macports/distfiles/bibutils
Error: org.macports.fetch for port bibutils returned: fetch failed
Please see the log file for port bibutils for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_tex_bibutils/bibutils/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port bibutils failed

Attachments (1)

main.log (4.1 KB) - added by paoloit@… 2 years ago.
logfile of failed installed (no distfile instance found)

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by paoloit@…

logfile of failed installed (no distfile instance found)

comment:1 Changed 2 years ago by paoloit@…

  • Cc paoloit@… added

Cc Me!

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Cc jochen@… added; paoloit@… removed
  • Keywords missing distribution corrupted removed
  • Owner changed from macports-tickets@… to ryandesign@…
  • Port @4.12_1 (tex) removed
  • Status changed from new to assigned
  • Summary changed from bibutils_4.12_src.tgz not available / corrupted to bibutils @4.12_1: distfile not available

Nothing is corrupted; the distfile is simply not available. This appears to be because the developer has configured their server to redirect all requests -- including requests for the bibutils distfile -- to the protein calculator web site.

It looks like the distfile is available at sourceforge so I'll update the port to use that download location.

comment:3 follow-up: Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 in reply to: ↑ 3 Changed 2 years ago by paoloit@…

Replying to ryandesign@…:

r141663

MANY thanks for the fast and effective remedial action! - I can confirm I could install bibutils without any problems!

Note: See TracTickets for help on using tickets.