Opened 7 years ago

Last modified 7 years ago

#49586 new defect

bash-completion doesn't always complete in /dev/

Reported by: miken32 (Michael Newton) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: upstream Cc:
Port: bash-completion

Description

This worked previously but stopped a couple of years ago. Trying to tab to my serial cable /dev/tty.usbserial as an argument to screen doesn't work. The only thing that completes from that directory is /dev/fd/3. Completion works fine with ls however. Let me know if I can provide any further details.

Change History (2)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: raimue@… removed
Owner: changed from macports-tickets@… to raimue@…

comment:2 Changed 7 years ago by raimue (Rainer Müller)

Keywords: upstream added

The problem is that the screen completion expects a command if no other options are specified. This was introduced in an upstream commit in 2011, see also the corresponding upstream bug report that caused this change.

I just tried the same on a Debian Linux system and it behaves in the same way. This bug is not specific to MacPorts or OS X and should be taken upstream to the bash-completion developers.

Note: See TracTickets for help on using tickets.