Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#49589 closed defect (duplicate)

gcc48 bug

Reported by: jianguohsiang82@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: elcapitan Cc:
Port: gcc48

Description (last modified by ryandesign (Ryan Schmidt))

I have tried downloading gcc48 several times. Nothing works:

sudo port -f install gcc48
Error: org.macports.build for port gcc48 returned: command execution failed
Please see the log file for port gcc48 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc48/gcc48/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gcc48 failed

The log file is several pages. I have tried cleaning the port. Nothing works. I first noticed this bug doing a full upgrade after the OS El Capitan update.

Change History (2)

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: elcapitan added
Port: gcc48 added
Resolution: duplicate
Status: newclosed

In the future, please provide the main.log file when you file a ticket. Without it, it's normally impossible for us to know why the build failed.

In this case, however, we already know that gcc48 will fail to build for all users running El Capitan.

Duplicate of #48471.

Note that using the "-f" flag is normally a bad idea. You normally should not use this flag.

comment:2 Changed 3 years ago by jianguohsiang82@…

"Note that using the "-f" flag is normally a bad idea. You normally should not use this flag."

I normally don't, but why is it a "bad idea"?

Note: See TracTickets for help on using tickets.