Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#49594 closed update (fixed)

root5 : Disable MathMore due to GSL 2.0 incompatibilities

Reported by: cjones051073 (Chris Jones) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc: mojca (Mojca Miklavec)
Port: root5

Description

Attached patch disables by default the gsl variant, which in turns enables the mathMore library to be built. This is because ROOT5 does not (yet, and perhaps never will ?) support GSL 2.0 where there have been API changes that break compilation.

Attachments (1)

root5.diff (1.3 KB) - added by cjones051073 (Chris Jones) 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by cjones051073 (Chris Jones)

Attachment: root5.diff added

comment:1 Changed 3 years ago by cjones051073 (Chris Jones)

For reference, upstream are aware of the issue

https://sft.its.cern.ch/jira/browse/ROOT-7776

comment:2 Changed 3 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed
Version: 2.3.4

Committed in r142498. The incompatibilites with GSL eventually resolved in r143637.

Last edited 3 years ago by mojca (Mojca Miklavec) (previous) (diff)

comment:3 Changed 3 years ago by mojca (Mojca Miklavec)

Similar commit for ROOT 6 in r143641.

Note: See TracTickets for help on using tickets.