Opened 6 years ago

Closed 6 years ago

#49596 closed defect (fixed)

selfupdate: rsync: failed to connect to rsync.macports.org: Operation timed out (60)

Reported by: vinay0410sharma@… Owned by: admin@…
Priority: High Milestone:
Component: server/hosting Version:
Keywords: Cc: bradjcox@…, ryandesign (Ryan Schmidt), satindersingh71@…
Port:

Description (last modified by ryandesign (Ryan Schmidt))

Computer: ~$ port -v selfupdate
--->  Updating MacPorts base sources using rsync
rsync: failed to connect to rsync.macports.org: Operation timed out (60)
rsync error: error in socket IO (code 10) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-47/rsync/clientserver.c(105) [receiver=2.6.9]
Command failed: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/tarballs/base.tar /opt/local/var/macports/sources/rsync.macports.org/release/tarballs
Exit code: 10
Error: Error synchronizing MacPorts sources: command execution failed
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: command execution failed

Change History (8)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Component: portsbase
Description: modified (diff)
Priority: HighNormal
Summary: command execution failedselfupdate: rsync: failed to connect to rsync.macports.org: Operation timed out (60)

Has this ever worked?

Maybe there is a network problem at your end.

Maybe there is a temporary server issue on our end. Try again later?

comment:2 Changed 6 years ago by rjderosa (Robert De Rosa)

I have the same issue.

--->  Updating MacPorts base sources using rsync
rsync: failed to connect to rsync.macports.org: Operation timed out (60)
rsync error: error in socket IO (code 10) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-47/rsync/clientserver.c(105) [receiver=2.6.9]
Command failed: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/tarballs/base.tar /opt/local/var/macports/sources/rsync.macports.org/release/tarballs
Exit code: 10
Error: Error synchronizing MacPorts sources: command execution failed
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: command execution failed

Also, I tried to ping rsync.macports.org and it just timed out. Has the address changed?

comment:3 Changed 6 years ago by mdeaudelin (Mathieu Deaudelin-Lemay)

Seems to be down for me too (and it used to work for me). Connection stays stuck on SYN_SENT, but no ACK is ever received.

To rderosa86@...: No the address has not changed. MacPorts' hosting provider has been experiencing intermittent issues over the last few months. This seems to be one of them.

You can wait for the service to be back up, or you can sync with the Subversion repository.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: bradjcox@… ryandesign@… added
Component: baseserver/hosting
Owner: changed from macports-tickets@… to admin@…
Priority: NormalHigh
Version: 2.3.4

Has duplicate #49615.

Keith, rsync.macports.org and distfiles.macports.org (same IP address) are not responding to pings or http requests.

comment:5 in reply to:  3 ; Changed 6 years ago by satindersingh71@…

Replying to macports@…: Does anyone know when it will be back up?

Seems to be down for me too (and it used to work for me). Connection stays stuck on SYN_SENT, but no ACK is ever received.

To rderosa86@...: No the address has not changed. MacPorts' hosting provider has been experiencing intermittent issues over the last few months. This seems to be one of them.

You can wait for the service to be back up, or you can sync with the Subversion repository.

comment:6 in reply to:  5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: satindersingh71@… added

Replying to satindersingh71@…:

Does anyone know when it will be back up?

I only just assigned the ticket to the administrator 8 minutes ago. I don't know how often he checks his messages or how long it will take him to figure out what the problem is and how to solve it.

comment:7 Changed 6 years ago by ryandesign (Ryan Schmidt)

Has duplicate #49616.

comment:8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

This got fixed sometime yesterday (?) or the day before. Thanks.

Note: See TracTickets for help on using tickets.