Opened 15 years ago

Closed 15 years ago

#4997 closed defect (worksforme)

BUG: xchat2 not displayed properly

Reported by: schmidt_r@… Owned by: mij@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

XChat2 doesn't show any user in the user list and also the field for number of ops and users remains empty. Then it doesn't give me tabs even though I want some. ;-)

OS ist Mac OS 10.4.2 with dp 1.100.

Change History (9)

comment:1 Changed 15 years ago by schmidt_r@…

op_sys: Mac OS X 10.0Mac OS X 10.4

comment:2 Changed 15 years ago by toby@…

Owner: changed from darwinports-bugs@… to mij@…

comment:3 Changed 15 years ago by fabian@…

Have the same problem, running on MacOS X 10.3.9 and DP 1.101, did an upgrade of glib2 and gtk2 just before and builded xchat2 2.4.5_0+darwin_7+ipv6

X-Chat does only open the server tab, but not any channel tabs. I was not able to connect to the Freenode IRC network, but could connect to an other irc network, which showed some strange behavior (GARBAGE messages). I got similar errors as reported on bug report "xchat-2.4.5 fails to open new channel tabs" [1]. Found through the official X-Chat Webiste at [2].

[1]

http://sourceforge.net/tracker/index.php?func=detail&aid=1301586&group_id=239&atid=100239

[2] http://www.xchat.org/

So this is not really a problem of DP, but one of X-Chat. As it seems to be fixed in the cvs version of X-Chat.

xchat2 2.4.4_0+darwin_7+ipv6 is still working in my DP setup.

Probably for the moment it would be good to change the version in the Portfile back to 2.4.4 until a patch is available from X-Chat.

comment:4 Changed 15 years ago by mij@…

Resolution: fixed
Status: newclosed

I just checked in patches that should fix this (it worked for me when I tested it). Please try it and let me know if you run into any problems.

comment:5 Changed 15 years ago by schmidt_r@…

Resolution: fixed
Status: closedreopened

comment:6 Changed 15 years ago by mij@…

Resolution: worksforme
Status: reopenedclosed

Then you've got problems elsewhere. The fixes I committed fixed the problem for me and a few others that tried it, so I'm not sure what to tell you...

Did you do an uninstall/reinstall of the port or an upgrade? If you did an upgrade, try uninstalling and reinstalling instead.

comment:7 Changed 15 years ago by schmidt_r@…

Resolution: worksforme
Status: closedreopened

Yesterday I did a complete reinstall of dp including xchat2. dp wasn't able to fetch the sources for xchat2, so I did download them from ftp and moved them into the appropriate directory. Then it compiled and installed properly. I changed nothing exept the gtk theme. But this shouldn't be the problem. It should work but it doesn't.

comment:8 Changed 15 years ago by mww@…

Summary: xchat2 not displayed properlyBUG: xchat2 not displayed properly

comment:9 Changed 15 years ago by markd@…

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.