Opened 4 years ago

Closed 4 years ago

#49986 closed defect (duplicate)

osxfuse installation aborts on the latest Xcode compiler

Reported by: mouse07410 (Mouse) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: osxfuse

Description (last modified by ryandesign (Ryan Schmidt))

Attempts to install osxfuse fail on El Capitan 10.11.2 with Xcode-7.2. Attached is the complete log, but this excerpt seems clear enough:

debug:main OS darwin/15.2.0 (Mac OS X 10.11) arch i386
:debug:main Sourcing PortGroup compiler_blacklist_versions 1.0 from /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/_resources/port1.0/group/compiler_blacklist_versions-1.0.tcl
:debug:main Reading variant descriptions from /opt/local/var/macports/sources/rsync....skipping...
am.h >@ file10 2>@stderr
:debug:patch euid/egid changed to: 0/0
:debug:patch chowned /opt/local/var/macports/build/_opt_local_var_macports_sources_r
sync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-b
f71481/kext/common/fuse_param.h to macports
:debug:patch euid/egid changed to: 503/501
:debug:patch euid/egid changed to: 0/0
:debug:patch setting attributes on /opt/local/var/macports/build/_opt_local_var_macp
orts_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osx
fuse-osxfuse-bf71481/kext/common/fuse_param.h
:debug:patch euid/egid changed to: 503/501
:debug:patch Privilege de-escalation not attempted as not running as root.
:debug:configure configure phase started at Fri Dec 11 18:13:12 EST 2015
:notice:configure --->  Configuring osxfuse
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing org.macports.configure (osxfuse)
:debug:configure Privilege de-escalation not attempted as not running as root.
:debug:build build phase started at Fri Dec 11 18:13:12 EST 2015
:notice:build --->  Building osxfuse
:debug:build Executing org.macports.build (osxfuse)
:debug:build Environment:
CC_PRINT_OPTIONS='YES'
CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources
_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/.CC_PRINT_OPTIO
NS'
CPATH='/opt/local/include'
LIBRARY_PATH='/opt/local/lib'
MACOSX_DEPLOYMENT_TARGET='10.11'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_ma
cports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/o
sxfuse-osxfuse-bf71481" && ./build.sh -t homebrew -f /opt/local'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-bf71481" && ./build.sh -t homebrew -f /opt/local
:info:build OSXFUSEBuildTool()            : skip unsupported Xcode version in '/Applications/Xcode.app/Contents/Developer'.
:info:build OSXFUSEBuildTool() failed: no supported version of Xcode found.

Plus, it seems to ignore the architecture requirement (in my system "build_arch" is set to x86_64) and seems to want to build for i386? Or maybe I'm misinterpreting that "i386" appearing above?.

Attachments (1)

main.log (311.6 KB) - added by mouse07410 (Mouse) 4 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by mouse07410 (Mouse)

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Priority: HighNormal

The Priority field is for Macports team members only, please do not change it.

comment:2 Changed 4 years ago by mdeaudelin (Mathieu Deaudelin-Lemay)

Duplicate of #49979

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Please use WikiFormatting.

Yes, you are misinterpreting the "i386" in the log. In that context, it just means an Intel processor, as opposed to a PowerPC processor (in which case it would say "powerpc").

Note: See TracTickets for help on using tickets.