Opened 4 years ago

Closed 3 years ago

#50049 closed defect (fixed)

phonon-backend-gstreamer: build error

Reported by: desertshadow@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: phonon-backend-gstreamer

Description (last modified by mf2k (Frank Schima))

Test on latest macports on OSX 10.8.4

sudo port install phonon-backend-gstreamer
:info:build /opt/local/include/gstreamer-1.0/gst/gstelement.h:55:10: fatal error: 'gst/gstconfig.h' file not found
:info:build #include <gst/gstconfig.h>

Full log attached

Attachments (1)

main.log (136.9 KB) - added by desertshadow@… 4 years ago.
Failure log.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by desertshadow@…

Attachment: main.log added

Failure log.

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to michaelld@…
Port: phonon-backend-gstreamer added
Summary: phonon_backend_gstreamer missing dependancy <gst/gstconfig.h>phonon-backend-gstreamer: build error

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers phonon-backend-gstreamer), if any.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:4 Changed 3 years ago by desertshadow@…

Looks like this is the official cause of the problem: https://git.reviewboard.kde.org/r/125690/

comment:5 Changed 3 years ago by desertshadow@…

I can confirm this issue also occurs on El Capitan, 10.11.3

comment:6 Changed 3 years ago by desertshadow@…

The file to edit in question is

work/build/gstreamer/CMakeFiles/phonon_gstreamer.dir/DependInfo.cmake

to add the include path:

/opt/local/lib/gstreamer-1.0/include/

I see no way for me to push this live for everyone, I think only the package maintainer can do this

Last edited 3 years ago by desertshadow@… (previous) (diff)

comment:7 Changed 3 years ago by desertshadow@…

I've tried for several hours to patch this, but I keep running into issues (such as comment:ticket:50870:1). It's a one liner, please patch soon. Thanks

Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:8 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.