Opened 2 years ago

Last modified 2 months ago

#50148 new defect

sudo port install kate goes to sleep on El Capitan 10.11.2

Reported by: imj-219@… Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: mkae (Marko Käning)
Port: kate

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

I installed MacPorts 2.3.4 for El Capitan, and after installing the prerequisites, the final step doesn't terminate.

Laughing it again, I get:

menu@macbookprojm:/opt/local > sudo port install kate
--->  Computing dependencies for kate
--->  Fetching archive for kate
--->  Attempting to fetch kate-4.14.3_1.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/kate
--->  Attempting to fetch kate-4.14.3_1.darwin_15.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/kate
--->  Attempting to fetch kate-4.14.3_1.darwin_15.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/kate
--->  Fetching distfiles for kate
--->  Attempting to fetch kate-4.14.3.tar.xz from ftp://ftp.solnet.ch/mirror/KDE/stable/4.14.3/src/
--->  Attempting to fetch kate-4.14.3.tar.xz from http://nue.de.distfiles.macports.org/macports/distfiles/kate
--->  Verifying checksums for kate                                                   
--->  Extracting kate
--->  Applying patches to kate
--->  Configuring kate

From another terminal, I can see the following:

menu@macbookprojm:/opt/local > ps ax | grep kate
30540 s000  S+     0:00.02 sudo port install kate
30541 s000  S+     0:07.23 /opt/local/libexec/macports/bin/tclsh8.5 /opt/local/bin/port install kate
30614 s000  S+     0:00.01 sh -c  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_kate/kate/work/build" && /opt/local/bin/cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_RPATH=/opt/local/lib -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DCMAKE_FIND_FRAMEWORK=LAST -Wno-dev -DCMAKE_MODULE_PATH="/opt/local/share/cmake/Modules;/opt/local/libexec/qt4/share/cmake/Modules" -DBUILD_doc=OFF -DBUILD_docs=OFF -DBUILD_SHARED_LIBS=ON -DBUNDLE_INSTALL_DIR=/Applications/MacPorts/KDE4 -DKDE_DISTRIBUTION_TEXT="MacPorts/Mac OS X" -DQT_QT_INCLUDE_DIR=/opt/local/libexec/qt4/include  -DQT_QMAKESPEC=macx-g++  -DQT_ZLIB_LIBRARY=/opt/local/lib/libz.dylib  -DQT_PNG_LIBRARY=/opt/local/lib/libpng.dylib -DDOCBOOKXSL_DIR=/opt/local/share/xsl/docbook-xsl -DGETTEXT_INCLUDE_DIR=/opt/local/include -DGETTEXT_LIBRARY=/opt/local/lib/libgettextlib.dylib -DGIF_INCLUDE_DIR=/opt/local/include -DGIF_LIBRARY=/opt/local/lib/libgif.dylib -DJASPER_INCLUDE_DIR=/opt/local/include -DJASPER_LIBRARY=/opt/local/lib/libjasper.dylib -DJPEG_INCLUDE_DIR=/opt/local/include -DJPEG_LIBRARY=/opt/local/lib/libjpeg.dylib -DLBER_LIBRARIES=/opt/local/lib/liblber.dylib -DLDAP_INCLUDE_DIR=/opt/local/include -DLDAP_LIBRARIES=/opt/local/lib/libldap.dylib -DLIBEXSLT_INCLUDE_DIR=/opt/local/include -DLIBEXSLT_LIBRARIES=/opt/local/lib/libexslt.dylib -DLIBICALSS_LIBRARY=/opt/local/lib/libicalss.dylib -DLIBICAL_INCLUDE_DIRS=/opt/local/include -DLIBICAL_LIBRARY=/opt/local/lib/libical.dylib -DLIBINTL_INCLUDE_DIR=/opt/local/include -DLIBINTL_LIBRARY=/opt/local/lib/libintl.dylib -DLIBXML2_INCLUDE_DIR=/opt/local/include/libxml2 -DLIBXML2_LIBRARIES=/opt/local/lib/libxml2.dylib -DLIBXML2_XMLLINT_EXECUTABLE=/opt/local/bin/xmllint -DLIBXSLT_INCLUDE_DIR=/opt/local/include -DLIBXSLT_LIBRARIES=/opt/local/lib/libxslt.dylib -DOPENAL_INCLUDE_DIR=/System/Library/Frameworks/OpenAL.framework/Headers -DOPENAL_LIBRARY=/System/Library/Frameworks/OpenAL.framework -DPNG_INCLUDE_DIR=/opt/local/include -DPNG_PNG_INCLUDE_DIR=/opt/local/include -DPNG_LIBRARY=/opt/local/lib/libpng.dylib -DTIFF_INCLUDE_DIR=/opt/local/include -DTIFF_LIBRARY=/opt/local/lib/libtiff.dylib -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.11" -DCMAKE_OSX_SYSROOT="/" /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_kate/kate/work/kate-4.14.3 
30615 s000  S+     0:01.45 /opt/local/bin/cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_RPATH=/opt/local/lib -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH=/opt/local;/usr -DCMAKE_FIND_FRAMEWORK=LAST -Wno-dev -DCMAKE_MODULE_PATH=/opt/local/share/cmake/Modules;/opt/local/libexec/qt4/share/cmake/Modules -DBUILD_doc=OFF -DBUILD_docs=OFF -DBUILD_SHARED_LIBS=ON -DBUNDLE_INSTALL_DIR=/Applications/MacPorts/KDE4 -DKDE_DISTRIBUTION_TEXT=MacPorts/Mac OS X -DQT_QT_INCLUDE_DIR=/opt/local/libexec/qt4/include -DQT_QMAKESPEC=macx-g++ -DQT_ZLIB_LIBRARY=/opt/local/lib/libz.dylib -DQT_PNG_LIBRARY=/opt/local/lib/libpng.dylib -DDOCBOOKXSL_DIR=/opt/local/share/xsl/docbook-xsl -DGETTEXT_INCLUDE_DIR=/opt/local/include -DGETTEXT_LIBRARY=/opt/local/lib/libgettextlib.dylib -DGIF_INCLUDE_DIR=/opt/local/include -DGIF_LIBRARY=/opt/local/lib/libgif.dylib -DJASPER_INCLUDE_DIR=/opt/local/include -DJASPER_LIBRARY=/opt/local/lib/libjasper.dylib -DJPEG_INCLUDE_DIR=/opt/local/include -DJPEG_LIBRARY=/opt/local/lib/libjpeg.dylib -DLBER_LIBRARIES=/opt/local/lib/liblber.dylib -DLDAP_INCLUDE_DIR=/opt/local/include -DLDAP_LIBRARIES=/opt/local/lib/libldap.dylib -DLIBEXSLT_INCLUDE_DIR=/opt/local/include -DLIBEXSLT_LIBRARIES=/opt/local/lib/libexslt.dylib -DLIBICALSS_LIBRARY=/opt/local/lib/libicalss.dylib -DLIBICAL_INCLUDE_DIRS=/opt/local/include -DLIBICAL_LIBRARY=/opt/local/lib/libical.dylib -DLIBINTL_INCLUDE_DIR=/opt/local/include -DLIBINTL_LIBRARY=/opt/local/lib/libintl.dylib -DLIBXML2_INCLUDE_DIR=/opt/local/include/libxml2 -DLIBXML2_LIBRARIES=/opt/local/lib/libxml2.dylib -DLIBXML2_XMLLINT_EXECUTABLE=/opt/local/bin/xmllint -DLIBXSLT_INCLUDE_DIR=/opt/local/include -DLIBXSLT_LIBRARIES=/opt/local/lib/libxslt.dylib -DOPENAL_INCLUDE_DIR=/System/Library/Frameworks/OpenAL.framework/Headers -DOPENAL_LIBRARY=/System/Library/Frameworks/OpenAL.framework -DPNG_INCLUDE_DIR=/opt/local/include -DPNG_PNG_INCLUDE_DIR=/opt/local/include -DPNG_LIBRARY=/opt/local/lib/libpng.dylib -DTIFF_INCLUDE_DIR=/opt/local/include -DTIFF_LIBRARY=/opt/local/lib/libtiff.dylib -DCMAKE_C_FLAGS_RELEASE=-DNDEBUG -DCMAKE_CXX_FLAGS_RELEASE=-DNDEBUG -DCMAKE_OSX_ARCHITECTURES=x86_64 -DCMAKE_OSX_DEPLOYMENT_TARGET=10.11 -DCMAKE_OSX_SYSROOT=/ /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_kate/kate/work/kate-4.14.3
31027 s001  S+     0:00.00 grep kate

Thanks for your help!

Jacques Menu

Change History (7)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Cc im-219@… removed
  • Description modified (diff)
  • Keywords install sleeps removed

How long did you wait? Compiling software can take awhile. Try using the debug flag (-d) to get more information. If it really is getting stuck, you can let us know the lines before it gets stuck.

sudo port clean kate
sudo port -d install kate

comment:2 in reply to: ↑ description Changed 2 years ago by imj-219@…

Replying to imj-219@…:

Hello,

I had let it "run" for more than half an hour, which should have been enough I guess.

With the "-d" option I get the following. Issue issue14018 didn't help, since Xcode is now installed elsewhere on El Capitan.

Thanks for your help!

...

-- The C compiler identification is AppleClang 7.0.2.7000181
-- The CXX compiler identification is AppleClang 7.0.2.7000181
CMake Warning at /opt/local/share/cmake-3.4/Modules/Platform/Darwin.cmake:197 (message):
  The SDK Library/Frameworks path

   //Library/Frameworks

  is not set up correctly on this system.  This is known to occur when
  installing Xcode 3.2.6:

   http://bugs.python.org/issue14018

  The problem may cause build errors that report missing system frameworks.
  Fix your SDK symlinks to resolve this issue and avoid this warning.
Call Stack (most recent call first):
  /opt/local/share/cmake-3.4/Modules/CMakeSystemSpecificInformation.cmake:36 (include)
  CMakeLists.txt:2 (project)


-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - not found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - found
-- Looking for QT_MAC_USE_COCOA
-- Looking for QT_MAC_USE_COCOA - found
-- Found Qt-Version 4.8.7 (using /opt/local/libexec/qt4/bin/qmake)
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - found
-- Found Threads: TRUE  
-- Found OpenSSL: /opt/local/lib/libssl.dylib;/opt/local/lib/libcrypto.dylib (found version "1.0.2e") 
-- Found Automoc4: /opt/local/bin/automoc4  
-- Found Perl: /opt/local/bin/perl (found version "5.22.1") 
-- Found Phonon: /opt/local/include (Required is at least version "4.3.80") 
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Found KDE 4.12 include dir: /opt/local/include
-- Found KDE 4.12 library dir: /opt/local/lib
-- Found the KDE4 kconfig_compiler preprocessor: /opt/local/bin/kconfig_compiler
-- Found automoc4: /opt/local/bin/automoc4
CMake Warning at /opt/local/share/apps/cmake/modules/MacroOptionalFindPackage.cmake:32 (find_package):
  Could not find a package configuration file provided by "KActivities"
  (requested version 6.1.0) with any of the following names:

    KActivitiesConfig.cmake
    kactivities-config.cmake

  Add the installation prefix of "KActivities" to CMAKE_PREFIX_PATH or set
  "KActivities_DIR" to a directory containing one of the above files.  If
  "KActivities" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:14 (macro_optional_find_package)


-- remember to port kate/plugins/filetemplate to new knewstuff2

and then things sleep.

Jacques Menu

Last edited 2 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Owner changed from macports-tickets@… to nicos@…

comment:4 Changed 2 years ago by ryandesign (Ryan Schmidt)

kate builds fine for me on El Capitan. On my system, the next line in the log after

-- remember to port kate/plugins/filetemplate to new knewstuff2

is

-- Found PythonInterp: /usr/bin/python (found version "2.7.10") 

The port does not specify which python to use. Possibly on your system it has found a python it doesn't like. What do you get if you run these commands:

which python
python -V

comment:5 Changed 2 years ago by imj-219@…

Hello,

Here is what I get:

menu@macbookprojm > which python
/opt/local/bin/python
menu@macbookprojm > python -V
Python 2.7.11

JM

Last edited 2 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:6 Changed 2 years ago by NicosPavlov

Hello, I just checked on my system (El Capitan 10.11.2), and it seems that the python version only does not trigger the blockage, as I also am using the macports version:

[...]
-- Found KDE 4.12 include dir: /opt/local/include
-- Found KDE 4.12 library dir: /opt/local/lib
-- Found the KDE4 kconfig_compiler preprocessor: /opt/local/bin/kconfig_compiler
-- Found automoc4: /opt/local/bin/automoc4
-- remember to port kate/plugins/filetemplate to new knewstuff2
-- Found PythonInterp: /opt/local/bin/python (found version "2.7.11") 
-- Python system site-packages directory: /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages
-- The Python files will be installed to /opt/local/lib/python2.7/site-packages. Make sure to add them to the Python search path (e.g. by setting PYTHONPATH)
-- Found PythonLibrary: /opt/local/lib/libpython2.7.dylib  
-- Found SIP version: 4.17
-- Found PyQt4 version: 4.11.4
[...]

comment:7 Changed 16 months ago by mkae (Marko Käning)

  • Cc mk@… added

Any update on this, imj-219?

Last edited 16 months ago by mkae (Marko Käning) (previous) (diff)
Note: See TracTickets for help on using tickets.