Opened 5 years ago

Closed 5 years ago

#50251 closed defect (duplicate)

problem installing octave on mac using macports - gnuplot issue

Reported by: roman@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: aquaterm

Description (last modified by ryandesign (Ryan Schmidt))

Hi all, I am a bit new to mac (had it only for a week) and I wanted to install Octave with GUI on it. I had some issues but I used this wiki: http://wiki.octave.org/Octave_for_MacOS_X (with MacPorts) and got this far: I get the following message after typing "sudo install octave +gui":

Romans-MBP:~ romanfrenkel$ sudo port  install octave +gui
Password:
--->  Computing dependencies for octave
--->  Dependencies to be installed: gnuplot aquaterm gd2 libvpx yasm xpm libcaca freeglut libGLU mesa indent py27-libxml2 xorg-dri2proto xorg-glproto xorg-libXdamage xorg-damageproto xorg-libXfixes xorg-fixesproto xorg-libXi xorg-libXmu xorg-libXrandr xorg-randrproto xrender xorg-renderproto xorg-libXxf86vm xorg-xf86vidmodeproto imlib2 giflib libid3tag libcerf lua pango Xft2 cairo glib2 pcre libpixman xorg-xcb-util gobject-introspection py27-mako py27-beaker py27-setuptools py27-markupsafe harfbuzz graphite2 wxWidgets-3.0 wxWidgets_select grep gsed hdf5 less pstoedit ImageMagick djvulibre librsvg gdk-pixbuf2 shared-mime-info intltool gnome-common autoconf-archive p5.22-getopt-long p5.22-pathtools p5.22-scalar-list-utils p5.22-xml-parser p5.22-libwww-perl p5.22-encode-locale p5.22-file-listing p5.22-http-date p5.22-html-form p5.22-html-parser p5.22-html-tagset p5.22-http-message p5.22-io-html p5.22-lwp-mediatypes p5.22-uri p5.22-mime-base64 p5.22-http-cookies p5.22-http-daemon p5.22-http-negotiate p5.22-lwp-protocol-https p5.22-io-socket-ssl p5.22-io-socket-inet6 p5.22-io p5.22-socket6 p5.22-io-socket-ip p5.22-net-libidn p5.22-net-ssleay p5.22-test-exception p5.22-sub-uplevel p5.22-test-simple p5.22-test-nowarnings p5.22-test-warn p5.22-mozilla-ca p5.22-net-http p5.22-www-robotrules gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl fop itstool libxslt openjade opensp source-highlight boost icu ctags libcroco vala jbigkit openexr ilmbase openjpeg urw-fonts plotutils qhull qrupdate qscintilla texinfo help2man p5.22-locale-gettext transfig imake tradcpp bsdmake xorg-cf-files netpbm libnetpbm
--->  Building aquaterm
Error: org.macports.build for port aquaterm returned: command execution failed
Error: Failed to install aquaterm
Please see the log file for port aquaterm for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/main.log
Error: The following dependencies were not installed: gnuplot aquaterm gd2 libvpx yasm xpm libcaca freeglut libGLU mesa indent py27-libxml2 xorg-dri2proto xorg-glproto xorg-libXdamage xorg-damageproto xorg-libXfixes xorg-fixesproto xorg-libXi xorg-libXmu xorg-libXrandr xorg-randrproto xrender xorg-renderproto xorg-libXxf86vm xorg-xf86vidmodeproto imlib2 giflib libid3tag libcerf lua pango Xft2 cairo glib2 pcre libpixman xorg-xcb-util gobject-introspection py27-mako py27-beaker py27-setuptools py27-markupsafe harfbuzz graphite2 wxWidgets-3.0 wxWidgets_select grep gsed hdf5 less pstoedit ImageMagick djvulibre librsvg gdk-pixbuf2 shared-mime-info intltool gnome-common autoconf-archive p5.22-getopt-long p5.22-pathtools p5.22-scalar-list-utils p5.22-xml-parser p5.22-libwww-perl p5.22-encode-locale p5.22-file-listing p5.22-http-date p5.22-html-form p5.22-html-parser p5.22-html-tagset p5.22-http-message p5.22-io-html p5.22-lwp-mediatypes p5.22-uri p5.22-mime-base64 p5.22-http-cookies p5.22-http-daemon p5.22-http-negotiate p5.22-lwp-protocol-https p5.22-io-socket-ssl p5.22-io-socket-inet6 p5.22-io p5.22-socket6 p5.22-io-socket-ip p5.22-net-libidn p5.22-net-ssleay p5.22-test-exception p5.22-sub-uplevel p5.22-test-simple p5.22-test-nowarnings p5.22-test-warn p5.22-mozilla-ca p5.22-net-http p5.22-www-robotrules gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl fop itstool libxslt openjade opensp source-highlight boost icu ctags libcroco vala jbigkit openexr ilmbase openjpeg urw-fonts plotutils qhull qrupdate qscintilla texinfo help2man p5.22-locale-gettext transfig imake tradcpp bsdmake xorg-cf-files netpbm libnetpbm
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port octave failed

I understand that the issue is probably associated with aquaterm - but I just can't build it, I tried to install it from source forge as a dmg. file, but the console does not recognise it when I type "aquaterm --version"

any help would be greatly appreciated - I have been trying to install octave for a few days now ... :/

Change History (1)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; roman@… removed
Description: modified (diff)
Keywords: gnuplot aqua term removed
Port: aquaterm added
Priority: HighNormal
Resolution: duplicate
Status: newclosed

We cannot know for sure what the problem is unless you attach the main.log file mentioned in the error message. But it is probable that you're experiencing the same problem everyone else with Xcode 7.2 is experiencing with aquaterm, which is described in #50040 and ProblemHotlist#xcode7.2.

Note: See TracTickets for help on using tickets.