Opened 5 years ago

Closed 2 years ago

#50326 closed defect (worksforme)

defect: hugin-app can't find Lensfun at configure

Reported by: mbrethen Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: hugin-app

Description

Hugin-app fails at configure with the following message:

:info:configure -- The C compiler identification is AppleClang 6.1.0.6020053
:info:configure -- The CXX compiler identification is AppleClang 6.1.0.6020053
:info:configure -- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
:info:configure -- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -- works
:info:configure -- Detecting C compiler ABI info
:info:configure -- Detecting C compiler ABI info - done
:info:configure -- Detecting C compile features
:info:configure -- Detecting C compile features - done
:info:configure -- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++
:info:configure -- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -- works
:info:configure -- Detecting CXX compiler ABI info
:info:configure -- Detecting CXX compiler ABI info - done
:info:configure -- Detecting CXX compile features
:info:configure -- Detecting CXX compile features - done
:info:configure -- Current HG revision is 4692917e7a55
:info:configure -- Assuming this is a tarball (release) build for 2013.0.0
:info:configure -- Looking for log2
:info:configure -- Looking for log2 - found
:info:configure -- Found wxWidgets: -L/opt/local/Library/Frameworks/wxWidgets.framework/Versions/wxWidgets/3.0/lib;;;-framework IOKit;-framework Carbon;-framework Cocoa;-framework AudioToolbox;-framework System;-framework OpenGL;-lwx_baseu-3.0;-lwx_osx_cocoau_core-3.0;-lwx_osx_cocoau_aui-3.0;-lwx_osx_cocoau_xrc-3.0;-lwx_osx_cocoau_html-3.0;-lwx_baseu_xml-3.0;-lwx_osx_cocoau_adv-3.0;-lwx_osx_cocoau_gl-3.0;-lwx_baseu_net-3.0 (found version "3.0.2") 
:info:configure -- Found TIFF: /opt/local/include
:info:configure -- Found JPEG: /opt/local/include
:info:configure -- Found ZLIB: /opt/local/include
:info:configure -- Found PNG: /opt/local/include
:info:configure -- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
:info:configure -- Found OPENEXR: /opt/local/lib/libImath.dylib;/opt/local/lib/libIlmImf.dylib;/opt/local/lib/libIex.dylib;/opt/local/lib/libHalf.dylib;/opt/local/lib/libIlmThread.dylib
:info:configure -- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
:info:configure -- Found Exiv2 release >= 0.12
:info:configure -- Found Exiv2: /opt/local/lib/libexiv2.dylib
:info:configure -- Found OpenGL: //System/Library/Frameworks/OpenGL.framework  
:info:configure -- GLUT Found
:info:configure -- Found Glew: /opt/local/lib/libGLEW.dylib
:info:configure -- libpano13 version: 2.9.19 major 2 minor 9 patch 19
:info:configure -- Boost version: 1.59.0
:info:configure -- Found the following Boost libraries:
:info:configure --   thread
:info:configure --   date_time
:info:configure --   regex
:info:configure --   filesystem
:info:configure --   iostreams
:info:configure --   system
:info:configure --   signals
:info:configure -- Program msgfmt found (/opt/local/bin/msgfmt)
:info:configure -- Looking for pthread.h
:info:configure -- Looking for pthread.h - found
:info:configure -- Looking for pthread_create
:info:configure -- Looking for pthread_create - found
:info:configure -- Found Threads: TRUE  
:info:configure -- ZThread library not found. falling back to included copy
:info:configure -- flann library found
:info:configure CMake Error at CMakeModules/FindPackageHandleStandardArgs.cmake:51 (MESSAGE):
:info:configure   Could not find REQUIRED package Lensfun
:info:configure Call Stack (most recent call first):
:info:configure   CMakeModules/FindLensfun.cmake:33 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
:info:configure   CMakeLists.txt:303 (FIND_PACKAGE)
:info:configure 
:info:configure 
:info:configure -- Configuring incomplete, errors occurred!
:info:configure See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_hugin-app/hugin-app/work/hugin-2013.0.0/CMakeFiles/CMakeOutput.log".
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_hugin-app/hugin-app/work/hugin-2013.0.0" && /opt/local/bin/cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_RPATH=/opt/local/lib -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DCMAKE_MODULE_PATH=/opt/local/share/cmake/Modules -DCMAKE_FIND_FRAMEWORK=LAST -Wno-dev -DINSTALL_OSX_BUNDLE_DIR=/Applications/MacPorts -DPYTHON_EXECUTABLE=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python -DPYTHON_INCLUDE_DIR=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -DPYTHON_LIBRARY=/opt/local/lib/libpython2.7.dylib -DwxWidgets_CONFIG_EXECUTABLE=/opt/local/Library/Frameworks/wxWidgets.framework/Versions/wxWidgets/3.0/bin/wx-config -DwxWidgets_wxrc_EXECUTABLE=/opt/local/Library/Frameworks/wxWidgets.framework/Versions/wxWidgets/3.0/bin/wxrc -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.10" -DCMAKE_OSX_SYSROOT="/" /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_hugin-app/hugin-app/work/hugin-2013.0.0 
:info:configure Exit code: 1
:error:configure org.macports.configure for port hugin-app returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"portconfigure::configure_main org.macports.configure"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:configure Warning: targets not executed for hugin-app: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port hugin-app for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_hugin-app/hugin-app/main.log

I manually installed the lensfun port and the error still occurs.

Attachments (1)

main.log (202.0 KB) - added by mbrethen 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Attach the complete main.log so we can diagnose the problem.

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers hugin-app), if any.

Last edited 5 years ago by mf2k (Frank Schima) (previous) (diff)

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

We already know hugin-app is old and needs to be updated. See #46721.

Changed 5 years ago by mbrethen

Attachment: main.log added

comment:3 Changed 5 years ago by mbrethen

Has anyone successfully built version 2015?

comment:4 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: changed from macports-tickets@… to MarcusCalhoun-Lopez
Port: hugin-app added
Status: newassigned

comment:5 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: assignedclosed

hugin-app no longer uses the lensfun library, so I think this ticket can safely be closed.

Note: See TracTickets for help on using tickets.