Opened 5 years ago

Closed 4 years ago

#50381 closed defect (fixed)

ncarg fails to build

Reported by: bmoebis@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: hdfeos

Description (last modified by mf2k (Frank Schima))

version:1
:debug:main Executing org.macports.main (hdfeos)
:debug:main Skipping completed org.macports.archivefetch (hdfeos)
:debug:main Skipping completed org.macports.fetch (hdfeos)
:debug:main Skipping completed org.macports.checksum (hdfeos)
:debug:main Skipping completed org.macports.extract (hdfeos)
:debug:main Skipping completed org.macports.patch (hdfeos)
:debug:main Skipping completed org.macports.configure (hdfeos)
:debug:build build phase started at Wed Jan 20 16:43:10 AEDT 2016
:notice:build --->  Building hdfeos
:debug:build Executing org.macports.build (hdfeos)
:debug:build Environment:
CC_PRINT_OPTIONS='YES'
CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/.CC_PRINT_OPTIONS'
CPATH='/opt/local/include'
LIBRARY_PATH='/opt/local/lib'
MACOSX_DEPLOYMENT_TARGET='10.11'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos" && /usr/bin/make -j8 -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos" && /usr/bin/make -j8 -w all
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos'
:info:build Making all in gctp
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/gctp'
:info:build Making all in src
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/gctp/src'
:info:build make[2]: Nothing to be done for `all'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/gctp/src'
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/gctp'
:info:build make[2]: Nothing to be done for `all-am'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/gctp'
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/gctp'
:info:build Making all in src
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/src'
:info:build /bin/sh ../libtool --mode=link --tag=CC /opt/local/bin/h4cc  -Os -arch x86_64 -I/opt/local/include  -Wl,-single_module -o libhdfeos.la -rpath /opt/local/lib  EHapi.lo GDapi.lo PTapi.lo SWapi.lo  -lmfhdf -ldf -lz -ljpeg -lm
:info:build libtool: link: warning: `/usr/local/lib/libsz.la' seems to be moved
:info:build libtool: link: warning: `/usr/local/lib/libsz.la' seems to be moved
:info:build /opt/local/bin/h4cc -dynamiclib -undefined dynamic_lookup -o .libs/libhdfeos.0.0.0.dylib  .libs/EHapi.o .libs/GDapi.o .libs/PTapi.o .libs/SWapi.o  /usr/local/lib/libmfhdf.a -L/usr/local/lib /usr/local/lib/libz.dylib /usr/local/lib/libdf.a -lz /usr/local/lib/libjpeg.dylib -lm -arch x86_64 -Wl,-single_module -install_name  /opt/local/lib/libhdfeos.0.dylib -Wl,-compatibility_version -Wl,1 -Wl,-current_version -Wl,1.0
:info:build clang: error: no such file or directory: '/usr/local/lib/libjpeg.dylib'
:info:build make[1]: *** [libhdfeos.la] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos/src'
:info:build make: *** [all-recursive] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/work/hdfeos" && /usr/bin/make -j8 -w all
:info:build Exit code: 2
:error:build org.macports.build for port hdfeos returned: command execution failed
:debug:build Error code: CHILDSTATUS 33873 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for hdfeos: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:error:build Failed to install hdfeos
:debug:build Registry error: hdfeos5 not registered as installed & active.
    invoked from within
"registry_active $subport"
    invoked from within
"$workername eval registry_active \$subport"
:notice:build Please see the log file for port hdfeos for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_hdfeos/hdfeos/main.log

Done with OSX 10.11.2

Attachments (1)

h4h5tools_main.log (51.6 KB) - added by bmoebis@… 4 years ago.
main.log from h4h5tools

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to takeshi@…
Port: hdfeos added

In the future, please use WikiFormatting, fill in the Port field with the port that fails to build and Cc the port maintainers (port info --maintainers hdfeos), if any.

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 5 years ago by tenomoto (Takeshi Enomoto)

Recently I fixed a bug in gcc5 in r148017 and made a significant changes to ncarg in r148018. Could you try again to see if the problem persists?

comment:4 Changed 4 years ago by bmoebis@…

it still fails to build hdfeos from main.log:

:info:build clang: error: no such file or directory: '/usr/local/lib/libjpeg.dylib'

search the file:

ls /usr/local/lib/libjpeg.*

/usr/local/lib/libjpeg.8.dylib /usr/local/lib/libjpeg.a /usr/local/lib/libjpeg.la

Last edited 4 years ago by bmoebis@… (previous) (diff)

comment:5 Changed 4 years ago by tenomoto (Takeshi Enomoto)

I can't reproduce the problem. The libraries from MacPorts, not in /usr/local should be correctly specified in configure. Could you issue the following command and attach main.log as a file?

$ sudo port selfupdate
$ sudo port upgrade outdated
$ sudo port clean hdfeos
$ sudo port build

comment:6 in reply to:  5 Changed 4 years ago by bmoebis@…

Replying to takeshi@…:

I can't reproduce the problem. The libraries from MacPorts, not in /usr/local should be correctly specified in configure. Could you issue the following command and attach main.log as a file?

$ sudo port selfupdate
$ sudo port upgrade outdated
$ sudo port clean hdfeos
$ sudo port build

clean did not help, but uninstall h4h5tools and uninstall hdfeos worked for install hdfeos and install ncarg. It seams h4h5tools is not a dependency anymore. Nevertheless h4h5tools still fails to build. I attached main.log from h4h5tools.

Changed 4 years ago by bmoebis@…

Attachment: h4h5tools_main.log added

main.log from h4h5tools

comment:7 Changed 4 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: newclosed

I updated h4h5tools to 2.2.2 in r148431. Now it uses hdf5-18 rather than hdf5. I added a library dependency to hdfeos. You should be able to open files in that format. I noticed that build will fail if hdf5-18 is built with one of MPI variants. Also you could use CMake for configuration. They are too much for me.

Note: See TracTickets for help on using tickets.