Opened 3 years ago

Closed 3 years ago

#50405 closed defect (duplicate)

MacVim on Lion failing with: error: use of undeclared identifier 'kCTFontOrient ationDefault'

Reported by: skymoo (Adam Mercer) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: MacVim

Description

I'm trying to build MacVim on an old Lion VM and I'm running into the following build error:

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_editors_MacVim/MacVim/work/macvim-90/src/MacVim/MMCoreTextView.m:1135:38: error: use of undeclared identifier 'kCTFontOrientationDefault'; did you mean 'kCTFontOptionsDefault'?
:info:build     CTFontGetAdvancesForGlyphs(font, kCTFontOrientationDefault, refG
lyphs,
:info:build                                      ^~~~~~~~~~~~~~~~~~~~~~~~~
:info:build                                      kCTFontOptionsDefault
:info:build /System/Library/Frameworks/ApplicationServices.framework/Frameworks/CoreText.framework/Headers/CTFont.h:203:5: note: 'kCTFontOptionsDefault' declared here
:info:build     kCTFontOptionsDefault               = 0,
:info:build     ^
:info:build 1 error generated.
:info:build 
:info:build 
:info:build ** BUILD FAILED **
:info:build 
:info:build 
:info:build The following build commands failed:
:info:build     CompileC build/MacVim.build/Release/MacVim.build/Objects-normal/i386/MMCoreTextView.o MMCoreTextView.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler

Full build log is attached.

Attachments (1)

main.log (227.3 KB) - added by skymoo (Adam Mercer) 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by skymoo (Adam Mercer)

Attachment: main.log added

comment:1 Changed 3 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #50018, reopening.

Note: See TracTickets for help on using tickets.