Opened 6 years ago

Closed 6 years ago

#50408 closed defect (duplicate)

aquaterm build failure

Reported by: caverac Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: elcapitan Cc:
Port: aquaterm

Description (last modified by ryandesign (Ryan Schmidt))

Hi there,

I recently upgraded to El Capitan and been trying, and failing, to install gnuplot. This is the terminal output

#### beginning output #####
--->  Computing dependencies for gnuplot
--->  Dependencies to be installed: aquaterm libcaca libcerf lua pango Xft2 wxWidgets-3.0 wxWidgets_select
--->  Building aquaterm
Error: org.macports.build for port aquaterm returned: command execution failed
Error: Failed to install aquaterm
Please see the log file for port aquaterm for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/main.log
Error: The following dependencies were not installed: aquaterm libcaca libcerf lua pango Xft2 wxWidgets-3.0 wxWidgets_select
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gnuplot failed
#### end ouput ####

And this is the log

#### begin main.log ####
version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Executing org.macports.main (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.configure (aquaterm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:build build phase started at Fri Jan 22 14:02:44 PST 2016
:notice:build --->  Building aquaterm
:debug:build Executing org.macports.build (aquaterm)
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm" && /usr/bin/xcodebuild  -target "AquaTerm" -configuration Default build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.11 ARCHS=x86_64 SDKROOT="" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++" LOCAL_APPS_DIR=/Applications/MacPorts LOCAL_FRAMEWORKS_DIR=/opt/local/Library/Frameworks'
:info:build Build settings from command line:
:info:build     ARCHS = x86_64
:info:build     CLANG_CXX_LIBRARY = libc++
:info:build     GCC_VERSION = com.apple.compilers.llvm.clang.1_0
:info:build     LOCAL_APPS_DIR = /Applications/MacPorts
:info:build     LOCAL_FRAMEWORKS_DIR = /opt/local/Library/Frameworks
:info:build     MACOSX_DEPLOYMENT_TARGET = 10.11
:info:build     OBJROOT = build/
:info:build     SDKROOT = 
:info:build     SYMROOT = build/
:info:build 
:info:build Could not find service "com.apple.CoreSimulator.CoreSimulatorService" in domain for uid: 502
:info:build 2016-01-22 14:02:45.473 xcodebuild[1914:5888060] launchctl print returned an error code: 28928
:info:build 2016-01-22 14:02:45.473 xcodebuild[1914:5888060] Failed to locate a valid instance of CoreSimulatorService in the bootstrap.  Adding it now.
:info:build Could not find service "com.apple.CoreSimulator.CoreSimulatorService" in domain for uid: 502
:info:build 2016-01-22 14:02:45.499 xcodebuild[1914:5888060] launchctl print returned an error code: 28928
:info:build 2016-01-22 14:02:45.499 xcodebuild[1914:5888060] *** Assertion failure in -[SimServiceContext reloadServiceIfMovedOrAbortIfWeAreInvalid], /BuildRoot/Library/Caches/com.apple.xbs/Sources/CoreSimulator/CoreSimulator-201.3/CoreSimulator/SimServiceContext.m:451
:info:build ** INTERNAL ERROR: Uncaught exception **
:info:build Exception: Unable to lookup com.apple.CoreSimulator.CoreSimulatorService in the bootstrap.  This can happen if running with a sandbox profile.  When running with a sandbox profile, make sure that com.apple.CoreSimulator.CoreSimulatorService.xpc is owned by root, not group writable, and not world writable.  See <rdar://problem/22142915>.
:info:build Stack:
:info:build   0  0x00007fff8b92baca __exceptionPreprocess (in CoreFoundation)
:info:build   1  0x00007fff8f1aaf7e objc_exception_throw (in libobjc.A.dylib)
:info:build   2  0x00007fff8b92b8ba +[NSException raise:format:arguments:] (in CoreFoundation)
:info:build   3  0x00007fff925ec88c -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] (in Foundation)
:info:build   4  0x00000001102ec2e5 -[SimServiceContext reloadServiceIfMovedOrAbortIfWeAreInvalid] (in CoreSimulator)
:info:build   5  0x00000001102ecc03 -[SimServiceContext connect] (in CoreSimulator)
:info:build   6  0x00000001102eb8bc -[SimServiceContext initWithConnectionType:] (in CoreSimulator)
:info:build   7  0x00000001102eb41a +[SimServiceContext simContextWithConnectionType:] (in CoreSimulator)
:info:build   8  0x00000001102eb3cb __41+[SimServiceContext sharedServiceContext]_block_invoke (in CoreSimulator)
:info:build   9  0x00007fff9a7d533f _dispatch_client_callout (in libdispatch.dylib)
:info:build  10  0x00007fff9a7d5237 dispatch_once_f (in libdispatch.dylib)
:info:build  11  0x00000001102eb3a9 +[SimServiceContext sharedServiceContext] (in CoreSimulator)
:info:build  12  0x000000011030b41a +[SimDeviceSet setForSetPath:] (in CoreSimulator)
:info:build  13  0x000000011030b3b6 +[SimDeviceSet defaultSet] (in CoreSimulator)
:info:build  14  0x0000000115d7bfe0 __42-[DVTiPhoneSimulatorLocator startLocating]_block_invoke (in IDEiOSSupportCore)
:info:build  15  0x000000010c231a58 __DVTDispatchAsync_block_invoke (in DVTFoundation)
:info:build  16  0x00007fff9a7e0871 _dispatch_call_block_and_release (in libdispatch.dylib)
:info:build  17  0x00007fff9a7d533f _dispatch_client_callout (in libdispatch.dylib)
:info:build  18  0x00007fff9a7d91cf _dispatch_root_queue_drain (in libdispatch.dylib)
:info:build  19  0x00007fff9a7d8a34 _dispatch_worker_thread3 (in libdispatch.dylib)
:info:build  20  0x00007fff9c96b68f _pthread_wqthread (in libsystem_pthread.dylib)
:info:build  21  0x00007fff9c969365 start_wqthread (in libsystem_pthread.dylib)
:info:build 
:info:build sh: line 1:  1914 Abort trap: 6           /usr/bin/xcodebuild -target "AquaTerm" -configuration Default build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.11 ARCHS=x86_64 SDKROOT="" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++" LOCAL_APPS_DIR=/Applications/MacPorts LOCAL_FRAMEWORKS_DIR=/opt/local/Library/Frameworks
:info:build Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm" && /usr/bin/xcodebuild  -target "AquaTerm" -configuration Default build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.11 ARCHS=x86_64 SDKROOT="" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++" LOCAL_APPS_DIR=/Applications/MacPorts LOCAL_FRAMEWORKS_DIR=/opt/local/Library/Frameworks
:info:build Exit code: 134
:error:build org.macports.build for port aquaterm returned: command execution failed
:debug:build Error code: NONE
:debug:build Backtrace: command execution failed
    while executing
"proc-org.macports.build-build-0 org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for aquaterm: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:error:build Failed to install aquaterm
:debug:build Registry error: wxWidgets_select not registered as installed & active.
    invoked from within
"registry_active $subport"
    invoked from within
"$workername eval registry_active \$subport"
:notice:build Please see the log file for port aquaterm for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/main.log
#### end main.log ####

Thanks for your help!

Change History (1)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: elcapitan added; gnuplot aquaterm removed
Port: aquaterm added
Resolution: duplicate
Status: newclosed
Summary: gnuplot doesn't work in El Capitan (V10.11.3)aquaterm build failure

Duplicate of #50040. See ProblemHotlist#xcode7.2.

Note: See TracTickets for help on using tickets.