Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#50513 closed defect (fixed)

py27-pep8: conflict with py27-pep8-157 on update

Reported by: langlois@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: petrrr, patrik.hartlen@…, eborisch (Eric A. Borisch)
Port: py-pep8 py-pep8-157

Description (last modified by dbevans (David B. Evans))

Hi, while upgrading outdated I've got the following conflict. Thank you for your help.

--->  Cleaning py27-spyder
--->  Computing dependencies for py-spyder
--->  Fetching archive for py-spyder
--->  Attempting to fetch py-spyder-2.3.8_0.darwin_10.noarch.tbz2 from http://lil.fr.packages.macports.org/py-spyder
--->  Attempting to fetch py-spyder-2.3.8_0.darwin_10.noarch.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/py-spyder
--->  Attempting to fetch py-spyder-2.3.8_0.darwin_10.noarch.tbz2 from http://nue.de.packages.macports.org/macports/packages/py-spyder
--->  Fetching distfiles for py-spyder
--->  Verifying checksums for py-spyder
--->  Extracting py-spyder
--->  Configuring py-spyder
--->  Building py-spyder
--->  Staging py-spyder into destroot
--->  Installing py-spyder @2.3.8_0
--->  Cleaning py-spyder
--->  Computing dependencies for py-spyder
--->  Deactivating py-spyder @2.3.7_0
--->  Cleaning py-spyder
--->  Activating py-spyder @2.3.8_0
--->  Cleaning py-spyder
--->  Computing dependencies for py27-pep8
Error: Unable to upgrade port: Can't install py27-pep8 because conflicting ports are active: py27-pep8-157

Change History (8)

comment:1 Changed 7 years ago by dbevans (David B. Evans)

Cc: petr@… patrik.hartlen@… added
Description: modified (diff)
Port: py-pep8 py-pep8-157 added
Summary: conflict py27-spyder@2.3.8_0 and py27-pep8-157py27-pep8: conflict with py27-pep8-157 on update
Version: 2.3.4

On future tickets please use WikiFormatting when quoting from terminal output or log files for better readibility, copy the port maintainers

port info --maintainer py27-pep8 py27-pep8-157

and fill in the Port field of the ticket. Thanks.

Note that, according to your terminal output, the conflict is between py27-pep8 and py27-pep8-157. Ports that have a dependency on py-pep8 currently depend on py-pep8-157 due to a regression in the 1.6.x series of py-pep8 that, in particular, effected py-flake8. Recently released py-pep8 1.7.0 claims to have fixed this issue so upgrading to this version as well as latest py-flake8 1.5.2 should allow this conflict to be removed.

In the meantime, if you really don't need to use py-pep8 1.6.x, just deactivate this port. No other ports currently depend on it.

sudo port deactivate py27-pep8

comment:2 Changed 7 years ago by petrrr

Cc: eborisch@… added

I can confirm that port py-pep8-157 was introduces to resolve an issue, regarding incompatibility with py-flake8, which remained unresolved upstream for quite some time. If pep 1.7.0 was finally released, this might now be fix and we could get back to one single port. Will look into this later.

Anyway, the conflict between py27-pep8 and py27-pep8-157 is by design. It's actually the same package, just a different version. In order to minimize any conflicts to occur for users with an existing install base, in r141870 I replaces the hard pep8 dependency with a path dependency. This way any of the two pep8 ports should satisfy the dependency. However, apparently for some reason this does not work for you.

I would suspect that some other port forces the installation of py27-pep8-157 (py27-flake, is the only good candidate I could think of), this cases py27-pep8 to be deactivated. However, py27-pep8 is part of the list of outdated ports. This is just a guess though, but if correct py27-pep8 now should already be deactivated. Another port upgrade outdated would not consider py27-pep8 and the upgrade will finish without error.

I CC the maintainer of py-spyder as well.

comment:3 Changed 7 years ago by petrrr

I updated pep8 to 1.7.0 in r145580, see also ticket #50576 (comment 4).

comment:4 Changed 7 years ago by petrrr

The py-pep8-157 was retired in r145602 (see also r145606).

Last edited 7 years ago by petrrr (previous) (diff)

comment:5 Changed 7 years ago by petrrr

r145607 removes the conflict with py-pep8-157.

comment:6 Changed 7 years ago by petrrr

Resolution: fixed
Status: newclosed

And as a side note: r145608 updated py-flake8.

comment:7 Changed 7 years ago by eborisch (Eric A. Borisch)

Thanks for handling this!

comment:8 Changed 7 years ago by langlois@…

Upgrade works well now! Many thanks Petr. Apologies for my initial ticket format. PhL.

Note: See TracTickets for help on using tickets.