Opened 5 years ago

Closed 4 years ago

#50551 closed defect (fixed)

octave-3.8.2 fails to configure on a MacBook Air 13" mid2012 with El Capitan 10.11.3

Reported by: shigemi.ohta@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: octave

Description (last modified by mf2k (Frank Schima))

--->  Attempting to fetch octave-3.8.2_15+atlas+gcc5+glgui+gui+qtgui.darwin_15.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/octave
--->  Fetching distfiles for octave
--->  Verifying checksums for octave
--->  Extracting octave
--->  Applying patches to octave
--->  Configuring octave
Error: Failed to configure octave, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-3.8.2/config.log
Error: org.macports.configure for port octave returned: configure failure: command execution failed
Please see the log file for port octave for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port octave failed

Attachments (5)

config.log (240.5 KB) - added by shigemi.ohta@… 5 years ago.
main.log (201.7 KB) - added by shigemi.ohta@… 5 years ago.
config.2.log (240.6 KB) - added by shigemi.ohta@… 5 years ago.
main.2.log (196.7 KB) - added by shigemi.ohta@… 5 years ago.
octave_atlas_nofortran_check.diff (445 bytes) - added by michaelld (Michael Dickens) 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by shigemi.ohta@…

Attachment: config.log added

Changed 5 years ago by shigemi.ohta@…

Attachment: main.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to michaelld@…
Port: octave added

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers octave), if any.

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 5 years ago by michaelld (Michael Dickens)

The issue is that, somehow, LAPACK is not being found. What does "port installed atlas" return?

If you haven't already, please try:

sudo port clean octave
sudo port selfupdate
sudo port upgrade outdated
sudo port install octave +atlas+gcc5+glgui+gui+qtgui

and see if that works. Sometimes cruft happens and cleaning it out works; sometimes not. Always worth a try. If this fails, then attach the new (whole, clean) build log to this ticket & post that you've added the attachment.

Last edited 5 years ago by michaelld (Michael Dickens) (previous) (diff)

Changed 5 years ago by shigemi.ohta@…

Attachment: config.2.log added

Changed 5 years ago by shigemi.ohta@…

Attachment: main.2.log added

comment:4 in reply to:  3 Changed 5 years ago by shigemi.ohta@…

Thank you. Unfortunately this did not work and resulted in apparently the same error. I am attaching the new logs.

Replying to michaelld@…:

The issue is that, somehow, LAPACK is not being found. What does "port installed atlas" return?

If you haven't already, please try:

sudo port clean octave
sudo port selfupdate
sudo port upgrade outdated
sudo port install octave +atlas+gcc5+glgui+gui+qtgui

and see if that works. Sometimes cruft happens and cleaning it out works; sometimes not. Always worth a try. If this fails, then attach the new (whole, clean) build log to this ticket & post that you've added the attachment.

comment:5 Changed 5 years ago by michaelld (Michael Dickens)

What does "port installed atlas" return?

comment:6 in reply to:  5 Changed 5 years ago by shigemi.ohta@…

Replying to michaelld@…:

What does "port installed atlas" return?

Thank you for this very useful suggestion. Indeed I had found atlas had been installed with +nofortran. So I was in a process of re-installing atlas with gfortran, which took more than 24 hours. After that octave configured and build without a problem, except a warning that arpack had been built with +accelerate and likely cause crash. So I am now trying to re-install arpack with +atlas, but that is a different story. Thank you again. A question, though, is why the port did not detect this atlas problem.

Changed 5 years ago by michaelld (Michael Dickens)

comment:7 Changed 5 years ago by michaelld (Michael Dickens)

Good suggestion! I had no idea that atlas +nofortran would fail. I don't use atlas (too long to build; I use openblas instead). Can you test the patch I just attached to this ticket to see if it works for you with your "atlas +nofortran" port active?

comment:8 Changed 4 years ago by michaelld (Michael Dickens)

Owner: changed from michaelld@… to macports-tickets@…

comment:9 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: changed from macports-tickets@… to mcalhoun@…
Status: newassigned

comment:10 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Octave has undergone significant changes recently (r148698).
Any chance this issue has been resolved?

comment:11 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed

With no further updates, let us assume this is now fixed.
If not, we can open a ticket specifically for octave 4.

Note: See TracTickets for help on using tickets.