Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#50621 closed defect (duplicate)

virtualbox 4.2.16: libcrypto not found at -I/opt/local/include /opt/local/lib/libcrypto.dylib /opt/local/lib/libssl.dylib or openssl headers not found

Reported by: 1-61803 Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: virtualbox

Description

on mp 2.3.4, osx 10.8.5, log attached

Attachments (2)

main.log (62.6 KB) - added by 1-61803 5 years ago.
configure.log (2.9 KB) - added by 1-61803 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by 1-61803

Attachment: main.log added

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Summary: virtualbox 4.2.16 fails to buildvirtualbox 4.2.16: libcrypto not found at -I/opt/local/include /opt/local/lib/libcrypto.dylib /opt/local/lib/libssl.dylib or openssl headers not found

The log says the problem is "libcrypto not found at -I/opt/local/include /opt/local/lib/libcrypto.dylib /opt/local/lib/libssl.dylib or openssl headers not found". Which is strange, because earlier in the log it said, as it should, that openssl @1.0.2f_0 is installed and active. So please check: do /opt/local/lib/libcrypto.dylib and /opt/local/lib/libssl.dylib actually exist? Does /opt/local/include/openssl/ actually exist?

Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 5 years ago by 1-61803

It seems it doesn't follow the links, but everything is in place.

$ ll /opt/local/lib/libcrypto.dylib
lrwxr-xr-x  1 root  admin    21B Jan 28 16:58:39 2016 /opt/local/lib/libcrypto.dylib -> libcrypto.1.0.0.dylib
$ ll /opt/local/lib/libssl.dylib
lrwxr-xr-x  1 root  admin    18B Jan 28 16:58:39 2016 /opt/local/lib/libssl.dylib -> libssl.1.0.0.dylib
$ ll -d /opt/local/include/openssl/
drwxr-xr-x  77 root  admin   2.6K Jan 28 16:58:38 2016 /opt/local/include/openssl/

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

I wouldn't leap to that diagnosis just yet.

Did you "Check the file /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_emulators_virtualbox/virtualbox/work/VirtualBox-4.2.16/configure.log for detailed error information"? You could attach that file here.

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

Changed 5 years ago by 1-61803

Attachment: configure.log added

comment:5 Changed 5 years ago by 1-61803

I attached configure.log. I have Xcode 5.1.1 (10.8/10.9 SDKs) installed. It seems the compiler is searching for 10.7's.

comment:6 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Ok, then this is a duplicate of #35808.

comment:7 Changed 5 years ago by 1-61803

#35808 opened 3 years ago? ok, it's improbable that this port will be updated

comment:8 Changed 5 years ago by ryandesign (Ryan Schmidt)

The port has no maintainer at this time, but anybody can volunteer to maintain a port and fix it.

Note: See TracTickets for help on using tickets.