Opened 3 years ago

Closed 3 years ago

#50623 closed enhancement (wontfix)

tmux: attach-session -dt (detach all others) broken

Reported by: Tatsh (Andrew Udvare) Owned by: tessus (Helmut K. C. Tessarek)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: tmux

Description

There is a bug in the latest tmux where if you pick a session or run attach-session -dt {name} that you actually just detach and the new session never loads.

tmux 2.1 affected by this bug. In #tmux one maintainer confirmed the bug and gave me a patch to HEAD but I made a similar patch for 2.1. This is attached.

Attachments (1)

fix-reattach-with-session-list.patch (421 bytes) - added by Tatsh (Andrew Udvare) 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Tatsh (Andrew Udvare)

comment:1 Changed 3 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to tessarek@…

comment:2 Changed 3 years ago by Tatsh (Andrew Udvare)

comment:3 Changed 3 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: newclosed

Fixed in r145936, maintainer timeout.

comment:4 Changed 3 years ago by tessus (Helmut K. C. Tessarek)

I've been sick and the notification mail got lost in my inbox. Anyway, I am against adding the fix to the release tmux. Please undo the last commit!!! There have been several bugs and fixes since 2.1 was released, so what? You want to add them all?

That is why there is a development version which is more recent than the release.

If you add all the fixes to the release you end up with the development version anyway.

comment:5 Changed 3 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: closedreopened

comment:6 Changed 3 years ago by neverpanic (Clemens Lang)

Resolution: wontfix
Status: reopenedclosed

Reverted in r145951. Sorry, I cannot know that you saw the ticket, because you did not acknowledge or comment on the ticket in any way. We have hundreds of ports that are just abandoned which is why we have a procedure for maintainer timeout.

I'm closing this as wontfix then, since it is my assumption that you don't want to fix this at this time?

Note: See TracTickets for help on using tickets.