Opened 15 years ago

Closed 15 years ago

Last modified 11 years ago

#5064 closed defect (fixed)

BUG: uninstall does not always remove files in dports/sfotware

Reported by: yves@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc: jberry@…, markd@…
Port:

Description (last modified by jmpp@…)

The situation is unfortunately not as clear as it would be in a perfect buggy world ... I will give what I have observed because this behaviour are not easy to repoduce

I run HEAD on 10.4.2 with Xcode 2.1

I uninstalled many ports on friday and saturday and found out that many were still present in dports/ software yesterday (sunday) while some had been deleted completely

But this is not, as I said, a coherent behavior -- Later on, I uninstalled ddd and everything got cleaned up ok (probably due to its awesome maintainer), I uninstalled jikes minutes later and it was still there in dports/software. "port installed" will say in either case that the port is not installed.

I have cleaned up my whole ${prefix}/share/darwinports/Tcl/port1.0/ directory yesterday too, but I can't say if it was before or after these two uninstall.

Hope that helps

Change History (6)

comment:1 Changed 15 years ago by jberry@…

Cc: jberry@… added

Hi Yves,

Any more comments on this bug? Do you have any clear reproducible cases?

-jdb

comment:2 Changed 15 years ago by markd@…

Cc: markd@… added

I assume this problem did not pursist at least in released DP 1.2; Can this be closed?

comment:3 Changed 15 years ago by yves@…

Resolution: fixed
Status: newclosed

comment:4 Changed 13 years ago by jmpp@…

Description: modified (diff)
Milestone: MacPorts base bugs

comment:5 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:6 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.