Opened 5 years ago

Closed 5 years ago

#50655 closed defect (duplicate)

openvpn2 @2.3.8_0 Unable to launch

Reported by: c5kolb Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: openvpn2

Description

I initially do and see the following:

$ cd /Library/LaunchDaemons
$ sudo launchctl load -w org.macports.openvpn2.plist
$ tail -f /var/log/system.log
Feb 17 10:51:17 xxx com.apple.xpc.launchd[1] (org.macports.openvpn2): The Debug key is no longer respected. Please remove it.
Feb 17 10:51:17 xxx com.apple.xpc.launchd[1] (org.macports.openvpn2): This service is defined to be constantly running and is inherently inefficient.
Feb 17 10:51:17 xxx com.apple.xpc.launchd[1] (org.macports.openvpn2): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Feb 17 10:51:47 --- last message repeated 2 times ---
Feb 17 10:51:47 xxx com.apple.xpc.launchd[1] (org.macports.openvpn2): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
...

This fails to launch openvpn2.

Next I try the following:

$ sudo launchctl unload -w org.macports.openvpn2.plist
$ cat org.macports.openvpn2.plist
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
"http://www.apple.com/DTDs/PropertyList-1.0.dtd" >
<plist version='1.0'>
<dict>
<key>Label</key><string>org.macports.openvpn2</string>
<key>ProgramArguments</key>
<array>
	<string>/opt/local/bin/daemondo</string>
	<string>--label=openvpn2</string>
	<string>--start-cmd</string>
	<string>/opt/local/sbin/openvpn2 --config /opt/local/etc/openvpn2/server.conf</string>
	<string>;</string>
	<string>--pid=exec</string>
</array>
<key>Debug</key><false/>
<key>Disabled</key><true/>
<key>KeepAlive</key><true/>
</dict>
</plist>
$ sudo /opt/local/sbin/openvpn2 --config /opt/local/etc/openvpn2/server.conf

This launches openvpn2 and I am able to connect with an openvpn2 client.

Next I try the following:

$ sudo sh -c "cat > org.macports.openvpn2.test.plist" << END
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
"http://www.apple.com/DTDs/PropertyList-1.0.dtd" >
<plist version='1.0'>
<dict>
<key>Label</key><string>org.macports.openvpn2</string>
<key>ProgramArguments</key>
<array>
        <string>/opt/local/sbin/openvpn2</string>
        <string>--config</string>
        <string>/opt/local/etc/openvpn2/server.conf</string>
</array>
<key>RunAtLoad</key>
<true/>
</dict>
</plist>
END
$ sudo launchctl load -w org.macports.openvpn2.test.plist

This also launches openvpn2 and I am able to connect with an openvpn2 client.

So... I can launch openvpn2 from the command line using the very same arguments that daemondo uses to start openvpn2. I can launch openvpn2 via daemondo from the command line using the very same arguments that the launchd.plist file uses to launch daemondo. I can create a launch.plist file that launches openvpn2 directly. But the launchd.plist file that comes with the openvpn2 port that uses daemondo to launch openvpn2 is not working.

This is all on a freshly [within the last 24 hours] installed [not upgraded] OS X [not OS X Server] 10.11 El Capitan system. On of our two OS X [Server] 10.8 Mountain Lion systems the same launchd.plist file launches daemondo/openvpn2 without issue. I have no experience with Mavericks or Yosemite as we are moving from Mountain Lion directly to El Capitan.

I did not find anything at macports.org or via Google that might help me with this.

Any light a that can be shed on this would be appreciated.

Change History (3)

comment:1 Changed 5 years ago by dbevans (David B. Evans)

Cc: kolbcp@… removed
Owner: changed from macports-tickets@… to jul_bsd@…
Port: openvpn2 added
Version: 2.3.4

Not necessary to CC yourself, reporter is always copied automatically. However, copying maintainer is a good idea.

$ port info --maintainer openvpn2

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from jul_bsd@… to macports-tickets@…

See #52039.

comment:3 Changed 5 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Let's call this a duplicate of #52525.

Note: See TracTickets for help on using tickets.