Opened 22 months ago

Last modified 4 months ago

#50828 new defect

wxWidgets-3.0-libcxx on 10.6 buildbot

Reported by: mojca (Mojca Miklavec) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: snowleopard Cc: jyrkiwahlstedt, ryandesign (Ryan Schmidt)
Port: wxWidgets-3.0-libcxx

Description

The build of wxWidgets-3.0-libcxx on 10.6 buildbot fails with:

install_name_tool -id /path/to/wxWidgets-3.0.2/build/lib/libwx_baseu-3.0.0.2.0.dylib /path/to/wxWidgets-3.0.2/build/lib/libwx_baseu-3.0.0.2.0.dylib
install_name_tool: object: /path/to/wxWidgets-3.0.2/build/lib/libwx_baseu-3.0.0.2.0.dylib malformed object (unknown load command 22)

It's not exactly clear to me whether this is an issue with the software or an issue with install_name_tool. (Maybe I can avoid running install_name_tool explicitly.)

Change History (1)

comment:1 Changed 4 months ago by kencu (Ken)

If this is still relevant, it's calling a too-old version of install_name_tool; we'd need to see how to make it use the macports version installed in ${prefix} instead.

Note: See TracTickets for help on using tickets.