Opened 4 years ago

Closed 4 years ago

#50919 closed defect (duplicate)

git build fails with ICE on Snow Leopard

Reported by: gnw3 Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: git

Description

$ sudo port -s upgrade outdated 
[sudo] password for gwhite@mutsu: 
--->  Computing dependencies for git
--->  Fetching distfiles for git
--->  Verifying checksums for git
--->  Extracting git
--->  Applying patches to git
--->  Configuring git
--->  Building git
Error: org.macports.build for port git returned: command execution failed
Please see the log file for port git for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_svn.macports.org_trunk_dports_devel_git/git/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

The relevant section of the log shows an ICE in /usr/bin/gcc-4.2

    :info:build /usr/bin/gcc-4.2 -o diffcore-delta.o -c -MF ./.depend/diffcore-delta
    .o.d -MQ diffcore-delta.o -MMD -MP  -I. -Wall -O2 -I/opt/local/include -arch x86
    _64 -I. -DPRECOMPOSE_UNICODE -DPROTECT_HFS_DEFAULT=1 -DUSE_LIBPCRE -I/opt/local/
    include -I/opt/local/include -DUSE_CURL_FOR_IMAP_SEND -I/opt/local/include -I/op
    t/local/include -DUSE_ST_TIMESPEC -DSHA1_MAX_BLOCK_SIZE="1024L*1024L*1024L"  -DH
    AVE_DEV_TTY -DXDL_FAST_HASH -DHAVE_BSD_SYSCTL -DSHA1_HEADER='<CommonCrypto/Commo
    nDigest.h>'  -DAPPLE_COMMON_CRYPTO -DCOMMON_DIGEST_FOR_OPENSSL -DNO_MEMMEM -Icom
    pat/regex -DSHELL_PATH='"/bin/sh"'  diffcore-delta.c
    :info:build combine-diff.c: In function ‘diff_tree_combined’:
    :info:build combine-diff.c:1391: internal compiler error: Segmentation fault
    :info:build Please submit a full bug report,
    :info:build with preprocessed source if appropriate.
    :info:build See <URL:http://developer.apple.com/bugreporter> for instructions.
    :info:build make: *** [combine-diff.o] Error 1

Since I don't expect Apple to fix this compiler, a workaround is:

sudo port -s upgrade git configure.compiler=macports-clang-3.6

Change History (1)

comment:1 Changed 4 years ago by ci42

Cc: ciserlohn removed
Keywords: ICE removed
Resolution: duplicate
Status: newclosed

Duplicate of #50869. For valid Keywords have a look at TicketsKeywordGuidelines.

Note: See TracTickets for help on using tickets.