Opened 5 years ago

Closed 5 years ago

#50993 closed defect (worksforme)

Atlas fails to configure

Reported by: oliverangelil (Oliver Angélil) Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: hergernadja@…
Port: atlas

Description

See log file attached.

"sudo port install octave" fails to build.

The port is also out of date, as Octave 4 has been released.

Thanks and regards,

Oliver

Attachments (1)

port_octave.log (1.6 KB) - added by oliverangelil (Oliver Angélil) 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by oliverangelil (Oliver Angélil)

Attachment: port_octave.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: michaelld@… openmaintainer@… removed
Owner: changed from macports-tickets@… to michaelld@…

Please do not Cc openmaintainer@… because it is not a valid email address.

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from michaelld@… to vince@…
Port: atlas added; octave removed

And attach the log file, fill in the Port field and Cc the maintainers for the port that actually fails to build.

comment:3 Changed 5 years ago by mf2k (Frank Schima)

Summary: Octave fails to installAtlas fails to configure

comment:4 Changed 5 years ago by michaelld (Michael Dickens)

If you do "port search octave" you'll find various "octave-devel*" ports that at version 4.0+. I'd recommend you using one of them instead of octave itself.

comment:5 in reply to:  4 Changed 5 years ago by oliverangelil (Oliver Angélil)

Replying to michaelld@…:

If you do "port search octave" you'll find various "octave-devel*" ports that at version 4.0+. I'd recommend you using one of them instead of octave itself.

That does not seem to work either. The process stops at "building octave-devel", and oddly new terminal windows continue to open and close automatically; one roughly every second. Certainly odd behaviour. I've also tested this on a second computer.

comment:6 in reply to:  4 Changed 5 years ago by oliverangelil (Oliver Angélil)

Replying to michaelld@…:

If you do "port search octave" you'll find various "octave-devel*" ports that at version 4.0+. I'd recommend you using one of them instead of octave itself.

With the new macports update (2.3.4), the installation (sudo port install octave) works. Atlas takes hours to build fyi.

comment:7 Changed 5 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.