Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#51019 closed defect (fixed)

ghostscript @9.19_0+x11 Checksum mismatch during upgrade

Reported by: astroboylrx (Rixin Li) Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: upstream Cc: dixiao@…, ewen-naos-nz (Ewen McNeill), mopihopi, hapaguy (Brian Kurt Fujikawa), u.g.the.sky@…, Miroboru (Tor Andre Myrvoll), MaurizioLoreti, Russell-Jones-OxPhys (Russell Jones), Schamschula (Marius Schamschula), majoc-at-astro (majoc-at-astro), mndavidoff (Monte Davidoff), erik@…, macdeport, dershow, tom.deal135@…, iqgrande, laurent.deniau@…, smuelasp@…, szekany-spam@…, Raimondi (Israel Chauca Fuentes)
Port: ghostscript

Description

Hi, I'm trying to upgrade the ghostscript port after a normal selfupdate. However, it seems the file on the server is wrong. I put error message below and also attach the log file.

➜  ~ sudo port upgrade outdated
--->  Computing dependencies for ghostscript
--->  Fetching archive for ghostscript
--->  Attempting to fetch ghostscript-9.19_0+x11.darwin_15.x86_64.tbz2 from https://packages.macports.org/ghostscript
--->  Attempting to fetch ghostscript-9.19_0+x11.darwin_15.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/ghostscript
--->  Attempting to fetch ghostscript-9.19_0+x11.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/ghostscript
--->  Fetching distfiles for ghostscript
--->  Verifying checksums for ghostscript
Error: Checksum (rmd160) mismatch for ghostscript-9.19.tar.gz
Error: Checksum (sha256) mismatch for ghostscript-9.19.tar.gz
Error: org.macports.checksum for port ghostscript returned: Unable to verify file checksums
Please see the log file for port ghostscript for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_ghostscript/ghostscript/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

Attachments (2)

main.log (7.7 KB) - added by astroboylrx (Rixin Li) 3 years ago.
The log file created during upgrading port ghostscript
ghostscript-github-latest-release-9.18.png (41.2 KB) - added by ewen-naos-nz (Ewen McNeill) 3 years ago.
Screenshot from github.com/.../ghostscript showing 9.18 "latest release"

Download all attachments as: .zip

Change History (34)

Changed 3 years ago by astroboylrx (Rixin Li)

Attachment: main.log added

The log file created during upgrading port ghostscript

comment:1 Changed 3 years ago by astroboylrx (Rixin Li)

Cc: astroboylrx@… added

Cc Me!

comment:2 Changed 3 years ago by astroboylrx (Rixin Li)

Thanks in advanced for those who will deal with this issue.

As far as I've seen, most servers seem still only have files for ghostscript-9.16. But "port selfupdate" said that there should be an update of ghostscript-9.19.

comment:3 Changed 3 years ago by neverpanic (Clemens Lang)

Cc: astroboylrx@… removed
Keywords: upstream added; checksum mismatch removed
Owner: changed from macports-tickets@… to cal@…
Status: newassigned
Type: updatedefect

You don't need to Cc yourself if you're the reporter.

I saw the same thing, but it seems this time the checksums have actually changed upstream and in addition no longer match those upstream provides in a SHA1SUMS file at https://github.com/ArtifexSoftware/ghostpdl-downloads/releases. Unfortunately I did not re-check whether the checksums were correct right before committing (they were three days ago).

I have contacted upstream about this. Let's wait for their reply.

Additionally, it doesn't help that SourceForge has problems at the moment and serves an HTML page with HTTP code 200 instead of actual files.

comment:4 Changed 3 years ago by dixiao@…

It seems #47786 hit again

comment:5 Changed 3 years ago by dixiao@…

Cc: dixiao@… added

Cc Me!

comment:6 Changed 3 years ago by ewen-naos-nz (Ewen McNeill)

Cc: macports@… added

Cc Me!

comment:7 Changed 3 years ago by ewen-naos-nz (Ewen McNeill)

AFAICT ghostscript-9.19 is being served out of github's archive only (the others that my system tries don't have it), which in turn is coming off S3. And it looks like maybe they rebuilt the archive again since the Portfile/SHA1SUMS were updated. In case it helps this is what I get when I download it manually:

ewen@ashram:~$ sha256sum ghostscript-9.19.tar.gz 
SHA256(ghostscript-9.19.tar.gz)= cf3c0dce67db1557a87366969945f9c5235887989c0b585e037af366dc035989
ewen@ashram:~$ openssl rmd160 ghostscript-9.19.tar.gz 
RIPEMD160(ghostscript-9.19.tar.gz)= 26acb114f30cbfa8f0e4912829a4ac38a35f5ea0
ewen@ashram:~$ sha1sum ghostscript-9.19.tar.gz 
695c56ecb296e9a0d97bc885c3180b0538aafbf5  ghostscript-9.19.tar.gz
ewen@ashram:~$ 

and also as downloaded by MacPorts:

ewen@ashram:/opt/local/var/macports$ sha256sum ./distfiles/ghostscript/ghostscript-9.19.tar.gz
SHA256(./distfiles/ghostscript/ghostscript-9.19.tar.gz)= cf3c0dce67db1557a87366969945f9c5235887989c0b585e037af366dc035989
ewen@ashram:/opt/local/var/macports$ openssl rmd160 ./distfiles/ghostscript/ghostscript-9.19.tar.gz
RIPEMD160(./distfiles/ghostscript/ghostscript-9.19.tar.gz)= 26acb114f30cbfa8f0e4912829a4ac38a35f5ea0
ewen@ashram:/opt/local/var/macports$ 

(one of those via a VPN/web proxy, and thus a different ISP.)

Possibly of note, https://github.com/ArtifexSoftware/ghostpdl-downloads/releases still shows 9.19 as "pre-release". 9.18 seems to be the current production release. Possibly the 9.19 archive is being rebuilt repeatedly for updated release candidates? Perhaps we want to go from 9.16 to 9.18 at this point, rather than 9.19?

Anyway, definitely good to find out what's actually going on before just accepting the new tarfile though :-)

Ewen

PS: Mostly for search bait: gimp2, groff, ImageMagick, and netpbm (and probably others) will all want to update ghostscript first before those updates can be installed.

comment:8 Changed 3 years ago by mopihopi

Cc: mopihopi@… added

Cc Me!

comment:9 Changed 3 years ago by hapaguy (Brian Kurt Fujikawa)

Cc: brian.fujikawa@… added

Cc Me!

comment:10 Changed 3 years ago by u.g.the.sky@…

Cc: u.g.the.sky@… added

Cc Me!

comment:11 Changed 3 years ago by Miroboru (Tor Andre Myrvoll)

Cc: myrvoll@… added

Cc Me!

comment:12 Changed 3 years ago by MaurizioLoreti

Cc: Maurizio.Loreti@… added

Cc Me!

comment:13 Changed 3 years ago by Russell-Jones-OxPhys (Russell Jones)

Cc: russell.jones@… added

Cc Me!

comment:14 Changed 3 years ago by Schamschula (Marius Schamschula)

Cc: mschamschula@… added

Cc Me!

comment:15 Changed 3 years ago by majoc-at-astro (majoc-at-astro)

Cc: majoc@… added

Cc Me!

comment:16 Changed 3 years ago by mndavidoff (Monte Davidoff)

Cc: md14-macports@… added

Cc Me!

comment:17 Changed 3 years ago by erik@…

Cc: erik@… added

Cc Me!

comment:18 in reply to:  7 Changed 3 years ago by macdeport

PS: Mostly for search bait: gimp2, groff, ImageMagick, and netpbm (and probably others) will all want to update ghostscript first before those updates can be installed.

and xpdf

comment:19 Changed 3 years ago by macdeport

Cc: als@… added

Cc Me!

comment:20 Changed 3 years ago by dershow

Cc: dersh@… added

Cc Me!

comment:21 Changed 3 years ago by tom.deal135@…

Cc: tom.deal135@… added

Cc Me!

comment:22 Changed 3 years ago by iqgrande

Cc: iqgrande@… added

Cc Me!

comment:23 Changed 3 years ago by laurent.deniau@…

Cc: laurent.deniau@… added

Cc Me!

comment:24 Changed 3 years ago by smuelasp@…

Cc Me!

comment:25 Changed 3 years ago by sangshimgm@…

Cc Me!

comment:26 Changed 3 years ago by smuelasp@…

Cc: smuelasp@… added

Cc Me!

comment:27 Changed 3 years ago by szekany-spam@…

Cc: szekany-spam@… added

Cc Me!

comment:28 in reply to:  7 ; Changed 3 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: assignedclosed

Fixed in r147287, after upstream confirmed the change was intentional and uploaded a new SHA1SUMS file.

Replying to macports@…:

Possibly of note, https://github.com/ArtifexSoftware/ghostpdl-downloads/releases still shows 9.19 as "pre-release". 9.18 seems to be the current production release. Possibly the 9.19 archive is being rebuilt repeatedly for updated release candidates? Perhaps we want to go from 9.16 to 9.18 at this point, rather than 9.19?

No. The topmost entry is 9.19 RC1, but the next one is 9.19 final. I'm not sure why GitHub orders them in this way.

comment:29 Changed 3 years ago by Raimondi (Israel Chauca Fuentes)

Cc: macports@… added

Cc Me!

comment:30 in reply to:  28 Changed 3 years ago by macdeport

Replying to cal@…:

Fixed in r147287, after upstream confirmed the change was intentional and uploaded a new SHA1SUMS file.

Thank you :-)

comment:31 in reply to:  7 Changed 3 years ago by KurtPfeifle (Kurt Pfeifle)

Replying to macports@…:

Possibly of note, https://github.com/ArtifexSoftware/ghostpdl-downloads/releases still shows 9.19 as "pre-release". 9.18 seems to be the current production release. Possibly the 9.19 archive is being rebuilt repeatedly for updated release candidates? Perhaps we want to go from 9.16 to 9.18 at this point, rather than 9.19?

Certainly of even better note: please scroll down on that page. You'll see a final release. GitHub sometimes orders entries on such pages in a funny way.

Changed 3 years ago by ewen-naos-nz (Ewen McNeill)

Screenshot from github.com/.../ghostscript showing 9.18 "latest release"

comment:32 in reply to:  28 Changed 3 years ago by ewen-naos-nz (Ewen McNeill)

Replying to cal@…:

No. The topmost entry is 9.19 RC1, but the next one is 9.19 final. I'm not sure why GitHub orders them in this way.

I agree that ordering the RC higher than the (apparently non RC) is confusing. But that wasn't my only source of confusion. The https://github.com/ArtifexSoftware/ghostpdl-downloads/releases showed (and still shows today; eg screenshot I just attached) the badge "Latest Release" against 9.18 (which is below 9.19). Which made me guess that, eg, Ghostscript was doing even=stable, odd=development release numbering.

From what you (and Kurt @ 31) say, and checking at http://ghostscript.com/download/ (which shows 9.19 downloads), it seems the github badge is just in the wrong place, and "9.19" should actually have that "Latest Release" badge. (The fact they all have the same "released on" dates on that github page doesn't help either -- but that's probably an artefact of uploading them all at once.)

Thanks for investigating and fixing the checksum mismatch.

Ewen

Note: See TracTickets for help on using tickets.