Opened 3 years ago

Closed 3 years ago

#51061 closed defect (fixed)

Building error in gspell

Reported by: thiagoveloso (Thiago V. dos Santos) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: gspell

Description

I tried to update my packages yesterday, and got an error when updating both gedit and gedit-plugins. The error is related to the gspell package. Essentially, what the error says is:

/System/Library/Frameworks/Foundation.framework/Headers/NSObjCRuntime.h:402:19: error: unknown type name 'NSString'; did you mean 'GString'?

There are dozens of the same error in multiple files. I have attached the complete error log to this message.

For the record, I am using the latest MacPorts (2.3.4) on a El Capitan Macbook Pro with the most recent Xcode (7.3).

Does anybody have a clue on how I can fix this?

Attachments (1)

main.log (119.1 KB) - added by thiagoveloso (Thiago V. dos Santos) 3 years ago.
Further details of the error I get when updating the gspell package.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by thiagoveloso (Thiago V. dos Santos)

Attachment: main.log added

Further details of the error I get when updating the gspell package.

comment:1 Changed 3 years ago by thiagoveloso (Thiago V. dos Santos)

One detail I forgot to mention: gedit was installed with the "+quartz" variant.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to devans@…
Port: gspell added

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers gspell), if any.

comment:3 in reply to:  2 Changed 3 years ago by thiagoveloso (Thiago V. dos Santos)

Replying to mf2k@…:

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers gspell), if any.

Thanks for the advice. I honestly did not know about this feature.

comment:4 Changed 3 years ago by dbevans (David B. Evans)

Problem confirmed and not specific to El Capitan. I have reproduced it on Yosemite as well. Looking to see if it has been reported upstream already. If not, will do so.

comment:5 Changed 3 years ago by dbevans (David B. Evans)

Patch to fix +quartz build issues committed in r147589. Works for me. Let me know if it works for you as well. This was something that was fixed in earlier versions but was broken again in 1.0. Thanks for your report.

comment:6 Changed 3 years ago by thiagoveloso (Thiago V. dos Santos)

I successfully updated both gedit and gedit-plugins. Confirmed to be working on my system too. Thank you Dave so much for the prompt response to this issue.

comment:7 Changed 3 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Glad it's working for you.

Note: See TracTickets for help on using tickets.