Opened 4 years ago

Closed 4 years ago

#51085 closed defect (invalid)

fusioninventory-agent: fails a test with 'Unable to resolve the UDP/IPv4 address "none")'

Reported by: mojca (Mojca Miklavec) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: dbevans (David B. Evans)
Port: fusioninventory-agent

Description

One of the tests in fusioninventory-agent fails:

t/agent/logger.t ................................. ok

#   Failed test 'instanciation: unresolvable host'
#   at t/agent/snmp/live.t line 52.
# expecting: Regexp ((?^:^Unable to resolve the UDP/IPv4 address "none"))
# found: no response from host none
# Looks like you failed 1 test of 12.
t/agent/snmp/live.t .............................. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/12 subtests 
	(less 6 skipped subtests: 5 okay)
t/agent/snmp/mock.t .............................. ok

Change History (2)

comment:1 Changed 4 years ago by dbevans (David B. Evans)

Works for me.

t/agent/logger.t ................................. ok
t/agent/snmp/live.t .............................. ok
t/agent/snmp/mock.t .............................. ok

It failed for you because your system responded with 'no response from host none' rather than 'Unable to resolve the UDP/IPv4 address "none"'.

If you look at the code in t/agent/snmp/live.t at line 52 and following you can see that the response you got is the one they expect for a resolvable host (1.1.1.1) that just isn't responding rather than a host named "none" that they assume to be unresolvable by DNS.

Perhaps "none" is a resolvable host on your system. What does

$ host none

tell you.

comment:2 Changed 4 years ago by mojca (Mojca Miklavec)

Resolution: invalid
Status: newclosed

It seems to be a bug in the settings of the router that belongs to my ISP. If I connect with DHCP, I automatically get domain <some-domain-that-resolves-everything> in /etc/resolv.conf. So whatever I try, ping whatever would resolve to an IP, followed by Request timeout for icmp_seq 0. I talked to tech support. The problem is temporary solved if I turn DHCP off and manually enter an IP address. They promised to look into it.

After turning DHCP off, I tried to run the test suite again and now it succeeds.

Note: See TracTickets for help on using tickets.