Opened 3 years ago

Closed 3 years ago

#51110 closed defect (fixed)

ipe @7.2.2 +qvoronoi fails to build on Mavericks

Reported by: bouttier__macports@… Owned by: m7.thon@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: ipe

Description (last modified by mf2k (Frank Schima))

Hi,

ipe currently fails to build on my Mac (OS 10.9.5). Below is the relevant part of the log. Thanks,

Jeremie

:info:build Compiling ipecanvas_cocoa.cpp...
:info:build /usr/bin/clang++ -arch x86_64 -mmacosx-version-min=10.8 -Wdeprecated-declarations -Wall -Wno-sign-conversion -g -Os -stdlib=libc++ -fPIC -DIPEUI_COCOA -std=c++11 -I../include -I../ipecairo -I/opt/local/include/cairo -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/libpng16 -I/opt/local/include -x objective-c++ -fobjc-arc   -c -o ../../build/obj/ipecanvas/ipecanvas_cocoa.o ipecanvas_cocoa.cpp
:info:build ipecanvas_cocoa.cpp:48:46: error: no visible @interface for 'NSGraphicsContext' declares the selector 'CGContext'
:info:build   return [[NSGraphicsContext currentContext] CGContext];
:info:build           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^~~~~~~~~
:info:build 1 error generated.

Attachments (1)

main.log (57.5 KB) - added by bouttier__macports@… 3 years ago.
full build log

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by bouttier__macports@…

Attachment: main.log added

full build log

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to m7.thon@…

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers ipe), if any.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by m7.thon@…

I forwarded this error report upstream to the ipe developer. For now, you should be able to compile ipe with the Qt interface instead:

sudo port install ipe +qt4

comment:4 Changed 3 years ago by m7.thon@…

I wrote a patch that should fix this and #51116. I attach the patch only to the newer #51116 to avoid duplication.

comment:5 Changed 3 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Patch committed in r147870. Now builds successfully on 10.9 both locally and on the buildbots.

Note: See TracTickets for help on using tickets.