Opened 5 years ago

Closed 5 years ago

#51134 closed defect (fixed)

vit broken by explicit perl dependency

Reported by: benjamin@… Owned by: g5pw (Aljaž Srebrnič)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: vit


Here's the offending change:

22 months ago, was changed to use '/usr/bin/env perl5.16'. Vit depends on the perl curses module which implies p5.16-curses, but that can't be installed because it is obsoleted. The vit package was (rightfully) updated to specify p5.22-curses as its dependency last year, but the file was not updated. New installs are now broken.

Should really specify a perl version at all? Why not just use the selected perl?

Change History (2)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to g5pw@…
Port: vit added

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers vit), if any.

Last edited 5 years ago by mf2k (Frank Schima) (previous) (diff)

comment:2 Changed 5 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed

I updated the patch in r147828. The reason I specify the perl version because vit depends on p5.22-curses, and AFAIK i can't specify a dependency on a "current version" perl package. I'm closing the ticket since the bug is fixed, but feel free to discuss.

Note: See TracTickets for help on using tickets.