Opened 3 years ago

Closed 3 years ago

#51143 closed update (fixed)

tmux @2.1 patch attached to update tmux to 2.2

Reported by: tessus (Helmut K. C. Tessarek) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: haspatch maintainer Cc: kurthindenburg (Kurt Hindenburg)
Port: tmux tmux-devel

Description

updated tmux Portfile to tmux 2.2

also updated tmux-devel to the commit point of the release

Attachments (2)

Portfile-tmux.diff (2.4 KB) - added by tessus (Helmut K. C. Tessarek) 3 years ago.
tmux.vim (5.3 KB) - added by tessus (Helmut K. C. Tessarek) 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:2 Changed 3 years ago by kurthindenburg (Kurt Hindenburg)

Does the tmux-devel work for you?

Error: Failed to destroot tmux-devel: no files matched glob pattern "/opt/local/var/macports/build/_Volumes_Projects_OtherSoftware_macports-trunk_dports_sysutils_tmux/tmux-devel/work/tmux-9a4b45dc0fdefead3fe9d471e144da78163860d0/examples/*.conf"

comment:3 Changed 3 years ago by tessus (Helmut K. C. Tessarek)

yes, I ran a port build tmux-devel before opening this ticket.

comment:4 Changed 3 years ago by kurthindenburg (Kurt Hindenburg)

Try 'port destroot tmux-devel' and see if you get the same error

comment:5 Changed 3 years ago by tessus (Helmut K. C. Tessarek)

Yes, I do. Good catch. Argh, in the future I will also run this command before submitting the patch.

I know what the problem is. I'll fix it tonight. Need to grab some food first.

Changed 3 years ago by tessus (Helmut K. C. Tessarek)

Attachment: Portfile-tmux.diff added

Changed 3 years ago by tessus (Helmut K. C. Tessarek)

Attachment: tmux.vim added

comment:6 Changed 3 years ago by tessus (Helmut K. C. Tessarek)

ok. done. new diff file attached. additionally, please put tmux.vim in the files directory. Thanks.

comment:7 Changed 3 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

done r147761

Note: See TracTickets for help on using tickets.