Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#51148 closed defect (duplicate)

LibreCAD not installing

Reported by: news24lor Owned by: librecad@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: dongxuli2011@…
Port: LibreCAD

Description (last modified by mf2k (Frank Schima))

It's impossible to install QGIS 2.14 on Mac OS X 10.11. These are the last rows in the log file...

......
:debug:main 	/opt/local=?
:debug:main Tracemode will respect recursively collected port dependencies: 
:debug:main Executing org.macports.main (LibreCAD)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Skipping completed org.macports.archivefetch (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.configure (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.build (LibreCAD)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:destroot destroot phase started at Thu Apr 14 14:56:48 CEST 2016
:notice:destroot --->  Staging LibreCAD into destroot
:debug:destroot Can't run destroot under sudo without elevated privileges (due to mtree).
:debug:destroot Run destroot without sudo to avoid root privileges.
:debug:destroot Going to escalate privileges back to root.
:debug:destroot euid changed to: 0. egid changed to: 0.
:info:destroot . missing (directory not created: File exists)
:info:destroot ./Applications missing (directory not created: File exists)
:info:destroot ./Developer missing (directory not created: File exists)
:info:destroot ./Library missing (directory not created: File exists)
:debug:destroot Tracelib Sandbox is:
:debug:destroot 	/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cad_LibreCAD/LibreCAD/work=+
:debug:destroot 	/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/cad/LibreCAD=+
:debug:destroot 	/opt/local/var/macports/distfiles/LibreCAD=+
:debug:destroot 	/bin=+
:debug:destroot 	/sbin=+
:debug:destroot 	/dev=+
:debug:destroot 	/usr/bin=+
:debug:destroot 	/usr/sbin=+
:debug:destroot 	/usr/include=+
:debug:destroot 	/usr/lib=+
:debug:destroot 	/usr/libexec=+
:debug:destroot 	/usr/share=+
:debug:destroot 	/System/Library=+
:debug:destroot 	/Library/Frameworks=-
:debug:destroot 	/Library=+
:debug:destroot 	/etc/passwd=+
:debug:destroot 	/private/etc/passwd=+
:debug:destroot 	/etc/groups=+
:debug:destroot 	/private/etc/groups=+
:debug:destroot 	/etc/localtime=+
:debug:destroot 	/private/etc/localtime=+
:debug:destroot 	/tmp=+
:debug:destroot 	/var/tmp=+
:debug:destroot 	/private/var/tmp=+
:debug:destroot 	/var/folders=+
:debug:destroot 	/private/var/folders=+
:debug:destroot 	/var/empty=+
:debug:destroot 	/private/var/empty=+
:debug:destroot 	/var/run=+
:debug:destroot 	/private/var/run=+
:debug:destroot 	/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cad_LibreCAD/LibreCAD/work/.tmp=+
:debug:destroot 	/var/db/xcode_select_link=+
:debug:destroot 	/private/var/db/xcode_select_link=+
:debug:destroot 	/var/db/mds=+
:debug:destroot 	/private/var/db/mds=+
:debug:destroot 	/opt/local/var/macports/home/Library/Preferences/com.apple.dt.Xcode.plist=+
:debug:destroot 	/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cad_LibreCAD/LibreCAD/work/.home/Library/Preferences/com.apple.dt.Xcode.plist=+
:debug:destroot 	/Applications/Xcode.app=+
:debug:destroot 	/var/db/launchd.db=+
:debug:destroot 	/private/var/db/launchd.db=+
:debug:destroot 	/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cad_LibreCAD/LibreCAD/work/.home/.ccache=+
:debug:destroot 	/opt/local/var/macports/build/.ccache=+
:debug:destroot 	/opt/local=?
:debug:destroot Tracemode will respect recursively collected port dependencies: boost bzip2 db48 dbus expat freetype gettext glib2 glibmm icu jpeg lcms2 libedit libffi libiconv libmng libpng libsigcxx2 libxml2 libxmlxx2 ncurses openssl pcre pkgconfig python27 python2_select python_select qt4-mac readline sqlite3 tiff xz zlib
:debug:destroot Executing org.macports.destroot (LibreCAD)
:info:destroot sh: macdeployqt: command not found
:info:destroot Command failed: macdeployqt LibreCAD.app
:info:destroot Exit code: 127
:error:destroot org.macports.destroot for port LibreCAD returned: command execution failed
:debug:destroot Error code: NONE
:debug:destroot Backtrace: command execution failed
    while executing
"proc-org.macports.destroot-destroot-0 org.macports.destroot"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:destroot Warning: targets not executed for LibreCAD: org.macports.activate org.macports.destroot org.macports.install
:notice:destroot Please see the log file for port LibreCAD for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cad_LibreCAD/LibreCAD/main.log

Change History (4)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: dongxuli2011@… added
Keywords: gis removed
Owner: changed from macports-tickets@… to librecad@…
Port: LibreCAD added

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers LibreCAD), if any.

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 5 years ago by g5pw (Aljaž Srebrnič)

Resolution: duplicate
Status: newclosed

Duplicate of #49843

comment:4 Changed 4 years ago by news24lor

Now the bug is fixed. LibreCAD is installed

Note: See TracTickets for help on using tickets.