Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#51165 closed defect (worksforme)

ncurses @6.0.0 does not provide libncurses.5.dylib needed by xcode

Reported by: Liontooth (David Liontooth) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: readline

Description

As I update my macports installation I find that ncurses 6 does not provide libncurses.5.dylib, which xcode is expecting. Downgrading to ncurses 5.9 solves the problem. Is the problem that my xcode is too old? This is not a bug in ncurses, but an upgrade path problem in some circumstances.

Cheers, David

csa@tmm:/usr/local/bin$ sudo port install ffmpeg-devel wget
--->  Fetching archive for ncurses
--->  Attempting to fetch ncurses-6.0_0.darwin_11.x86_64.tbz2 from http://osl.no.packages.macports.org/ncurses
--->  Attempting to fetch ncurses-6.0_0.darwin_11.x86_64.tbz2.rmd160 from http://osl.no.packages.macports.org/ncurses
--->  Installing ncurses @6.0_0
--->  Cleaning ncurses
--->  Deactivating ncurses @5.9_2
--->  Cleaning ncurses
--->  Activating ncurses @6.0_0
--->  Cleaning ncurses
-...
:info:configure config.status: creating Makefile
:info:configure dyld: Library not loaded: /opt/local/lib/libncurses.5.dylib
:info:configure   Referenced from: /opt/local/lib/libreadline.6.dylib
:info:configure   Reason: no suitable image found.  Did find:
:info:configure         /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
:info:configure sed: stdout: Broken pipe
:info:configure ./config.status: line 1279: 47859 Done(1)                 eval sed \"\$ac_sed_extra\" "$ac_file_inputs"
:info:configure      47860 Trace/BPT trap: 5       | $AWK -f "$ac_tmp/subs.awk" > $ac_tmp/out
:info:configure config.status: error: could not create Makefile
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_audio_lame/lame/work/lame-3.99.5" && ./configure --prefix=/opt/local 
:info:configure Exit code: 1
:error:configure Failed to configure lame, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_audio_lame/lame/work/lame-3.99.5/config.log
:error:configure org.macports.configure for port lame returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"portconfigure::configure_main org.macports.configure"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:configure Warning: targets not executed for lame: org.macports.install org.macports.configure org.macports.build org.macports.destroot
:notice:configure Please see the log file for port lame for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_audio_lame/lame/main.log
csa@tmm:/usr/local/bin$ sudo port activate ncurses @5.9_2
Error: 
Error: No valid Xcode installation is properly selected.
Error: Please use xcode-select to select an Xcode installation:
Error:     sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer # version 4.3.3
Error:     sudo xcode-select -switch /Developer # version 4.2
Error: 
Warning: xcodebuild exists but failed to execute
Warning: Xcode does not appear to be installed; most ports will likely fail to build.
--->  Deactivating ncurses @6.0_0
--->  Cleaning ncurses
--->  Activating ncurses @5.9_2
--->  Cleaning ncurses

Change History (4)

comment:1 Changed 3 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to mcalhoun@…
Port: readline added

The problem is not Xcode, but the readline library in /opt/local/lib/libreadline.6.dylib, which is used during the build of the lame port. The readline port that installs this library was rev-bumped in r139469, so MacPorts should have rebuilt it first (unless lame or one of its dependencies does not declare a dependency on readine).

Additionally, rev-upgrade (which runs after each successful installation or upgrade by default) should have caught this problem and rebuilt readline against the new version of ncurses.

comment:2 Changed 3 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Status: newassigned

I am not sure why this is happening, but let's try to track down the problem.
What is the output of

port installed readline

?

comment:3 Changed 3 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: assignedclosed

According to an e-mail from the original poster, reinstallation fixed the problem.
Closing ticket since no one can reproduce the problem anymore.

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

There's nothing to track down really. It's all explained at wiki:ProblemHotlist#ncurses6

Note: See TracTickets for help on using tickets.