Opened 3 years ago

Closed 3 years ago

#51176 closed defect (worksforme)

New libtorrent-rasterbar 1.1.0 seems to break current deluge @1.3.12_1+python27

Reported by: beremour Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: deluge libtorrent-rasterbar

Description (last modified by mf2k (Frank Schima))

After upgrading to libtorrent-rasterbar @1.1_0+python27 my current torrent app deluge @1.3.12_1+python27 stops downloading or uploading anything. Activating the old one libtorrent-rasterbar @1.0.9_0+python27 brings all back to work.

my OS is LION

bash-3.2$ uname -a
Darwin MACPRO11.local 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:26:45 PDT 2012; root:xnu-1699.32.7~1/RELEASE_I386 i386

Change History (9)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Keywords: deluge removed
Owner: changed from macports-tickets@… to devans@…
Port: deluge added

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers libtorrent-rasterbar), if any.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by beremour

thanx for editing

comment:4 Changed 3 years ago by dbevans (David B. Evans)

Status: newassigned

I've tested on El Capitan and Yosemite (no Lion available) but I ran into a possibly similar problem when initially running deluge with libtorrent-rasterbar 1.11. In my case, deluge downloaded torrents but only using IPv6 peers. After shutting down deluge (including the daemon) and then restarting, IPv4 peers began to appear and I was able to download several large (4GB+) torrents (Fedora DVD images) without further problems.

If this doesn't work for you, you'll need to run the daemon in debug mode, compare its log output to the results you get running with the previous version and see if you can determine what the issue is.

comment:5 Changed 3 years ago by dbevans (David B. Evans)

On further testing today, I find that each time I startup, I get a different behavior, sometimes working, sometimes work partially and sometimes not working at all. Running the deluge daemon in debug mode, I see a python error (that is apparently ignored) concerning an unsupported attribute asssociated with a settings dictionary. This appears to be the cause of the issue reported here.

Have committed an upstream patch to ensure the python bindings are backwards compatible with version 1.0 in r147874 which seems to have solved this issue for me. Let me know if it resolves your issues as well.

comment:6 Changed 3 years ago by beremour

Sorry, but no

sh-3.2$ sudo port installed actinact
The following ports are currently installed:
  libtorrent-rasterbar @1.0.9_0+python27
  libtorrent-rasterbar @1.1_1+python27 (active)

deluge daemon stucks

comment:7 Changed 3 years ago by beremour

sh-3.2$ sudo port installed actinact
The following ports are currently installed:
  libtorrent-rasterbar @1.0.9_0+python27 (active)
  libtorrent-rasterbar @1.1_1+python27

makes Deluge daemon alive

comment:8 Changed 3 years ago by dbevans (David B. Evans)

Please make sure you have shut down the old daemon and then restarted with the new version of libtorrent-rasterbar. If this doesn't work you need to try and debug the issue as outlined in comment:4. Currently deluge is working well for me using libtorrent-rasterbar 1.1. You may want to contact the upstream developers as well for advice.

comment:9 Changed 3 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.