Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#51187 closed defect (fixed)

p5.22-email-sender requires Net::SMTP 3.07 but perl5.22 only provides 3.05

Reported by: detlevd (Detlev Droege) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: perl5.22

Description

When calling perl script containing

require Email::Sender::Transport::SMTP;

from p5.22-email-sender it issues

  Net::SMTP version 3.07 required--this is only version 3.05 at /opt/local/lib/perl5/vendor_perl/5.22/Email/Sender/Transport/SMTP.pm line 11.
  BEGIN failed--compilation aborted at /opt/local/lib/perl5/vendor_perl/5.22/Email/Sender/Transport/SMTP.pm line 11.
  Compilation failed in require at sendMails.pl line 29.

Net::SMTP is part of the main Perl package perl5.22 and is version 3.05:

  $ grep VERSION.= /opt/local/lib/perl5/5.22/Net/SMTP.pm
  our $VERSION = "3.05";
  $ port provides /opt/local/lib/perl5/5.22/Net/SMTP.pm
  /opt/local/lib/perl5/5.22/Net/SMTP.pm is provided by: perl5.22

The installed packages are the current ones

$ port installed perl5.22 p5.22-email-sender
The following ports are currently installed:
  p5.22-email-sender @1.300.27_0 (active)
  perl5.22 @5.22.1_1 (active)

Please upgrade perl5.22 to provide the required version 3.07 of Net::SMTP !

Change History (3)

comment:1 Changed 3 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Dependency on p5-net which provides latest Net::SMTP version 3.08 added in r147926. Thanks for the report.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Keywords: version conflict removed

comment:3 Changed 3 years ago by detlevd (Detlev Droege)

Thanks for the fix!

Note: See TracTickets for help on using tickets.