Opened 5 years ago

Closed 5 years ago

#51188 closed defect (duplicate)

Exiting python35 leaves bash in echo off mode

Reported by: sporring@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: python35

Description

Hi,

When exiting python35 (ctrl-D) then bash is in a non-standard state, where keyboard input is not echoed. "stty echo" fixes the issue.

Best, Jon


FN11194:~ sporring$ port info python35
python35 @3.5.1_1 (lang)
Variants:             readline, universal

Description:          Python is an interpreted, interactive, object-oriented
                      programming language.
Homepage:             http://www.python.org/

Extract Dependencies: xz
Library Dependencies: zlib, openssl, sqlite3, ncurses, bzip2, libedit, gettext,
                      xz
Runtime Dependencies: python_select, python3_select
Platforms:            darwin
License:              PSF
Maintainers:          jwa@macports.org, openmaintainer@macports.org

Change History (3)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jwa@…
Port: python35 added

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers python35), if any.

comment:2 Changed 5 years ago by stromnov (Andrew Stromnov)

Possible duplicate of #48807.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

I assume so.

Note: See TracTickets for help on using tickets.